HobbyCNC fórum
  v0.9.2.4

Fórum betekintő Fórum címe: http://forum.hobbycnc.hu



DC szervó motoros vezérlés

Step/dir vezérlő programmal...


Időrend:
Oldal 3 / 261 Ugrás ide:
|◄ Első  ◄ Előző  1 2 3  4   5   6   7     Következő ►  Utolsó ►|

Fórum főoldal  |  A lap aljára

Kisamotors | 517    2016-08-05 16:45:00 [13104]

Tök egyszerű, ha fordított a polaritás a tengelyen keletkező nyomatéknak nem ellenntart, hanem azzal azonos irányban mozdítja a motort.
Növekszik a hiba, növeli az áramot (kitöltést).
Ezért még gyorsabban forog a rossz irányba és így tovább, míg a hiba el nem éri a kritikus szintet és lekapcsol.
Mekkora fizikai osztású az encodered, és mi az összáttétel?

Beállított PPR x 4 impulzust ad az encoder.
(2. All resolutions stated are before quadrature decoding. (example: 1000 ppr x 4 = 4000 counts)


tambi | 19    2016-08-05 11:49:00 [13103]

Köszönöm kedves Kisamotors!!! Motor polaritáscserétől rögtön megjavult. Míg élek sem jöttem volna rá...Nem is értem, hogyan lehetséges ez???? Sőt azt sem értem, hogyan lehet a fordulat lézerrel mérve 3000, ha a Mach3-ban 25 a step/mm, 46140 mm/sec a sebesség, 1000 pulzus/fordulat az encoder beállítása, 2 a szorzója??? Előre is köszönöm!!!


Kisamotors | 517    2016-08-04 18:39:00 [13102]

Fordítsd meg a motor polaritását, vagy cseréld meg az encoder A-B csatlakozóját.

Előzmény: tambi, 2016-08-04 18:32:00 [13101]


tambi | 19    2016-08-04 18:32:00 [13101]

Kedves Gvox, Amatőr és más segítőim!
Ma elkészült a 70V-os (2x24V egyenirányítva, 4x6800 uF/100V kondival szűrve). Mindent összedugtam, majd bekapcsoltam a hálózatot. (Ezt bírnia kell ,minden részegységnek, hiszen ez az üzemszerű bekapcsolás). A motor minden vezérlés nélkül felpörgött, talán túl is a 3000 ford/percen, majd a vezérlő kikapcsolta a motort, a piros LED ismét felváltva villogott a zölddel. Ezt a jelenséget a 70V-ról semmilyen módszerrel, Mach3-al, Servoconfig3-al megszüntetni nem tudtam. Ekkor levettem a csatlakozót a tápról, és átdugtam a FOK-GYEM 38,8V-jába. A vezérlőben lévő, 70 V-ra töltött 470 uF/200V-os kondi nyomott egy szikrát a 38,8V-os táp felé. Ettől eltekintve a "feszültség visszacsökkentése" rendben lezajlott, de a jelenség továbbra is ugyanaz. Mindkét szoftverrel vezérelve a motor néhány tized másodpercre felpörög, piros LED, DG4S-16035 vezérlő általi tápelvétel. Természetesen szétszedtem a vezérlőt, a de a négy motormeghajtó FET Ohm-mérővel mérve jónak tűnik, annyi bizonyos, hogy nem totálzárlatos egyik sem. Van valami elképzelésetek, hogy mi a manó?????????
Köszönettel; Tambi
(Az AMT103 encoder "100/fordulat" osztásra van állítva)


gvox | 181    2016-08-03 21:59:00 [13100]

A DG4S-160-35 PWM je csak 80% ig nyitható ezért a tápfeszülségből 20% ot vesztesz, emeld meg a tápfeszt hogy a motorra a névleges fesz kerülhessen

tambi | 19    2016-08-02 17:02:00 [13099]

Bármilyen szégyenletes, kezdő (még csöves) TV-szerelő koromban egyszer előfordult, hogy a biztosítékot néztem meg utoljára... Direktben hajtva FOK-GYEM TR-9158-al 38,8V-ról 0,33A-t vesz fel, és lézeres fordulatszámmérővel (DT-2234C+) mérve 2874-t forog... Igazam volt Barátaim, saját hülyeségem kergetett volna az őrületbe, ha Amatőr fórumtársunk nem nyitja fel a szemem. Köszönet érte!!!

Előzmény: Amatőr, 2016-08-02 12:00:00 [13098]


Amatőr | 2045    2016-08-02 12:00:00 [13098]

Ha a motort simán a tápfeszre kötöd forogna gyorsabban? Elég az a tápfesz hogy 2200 fölé vigye a motort?

Előzmény: tambi, 2016-08-02 11:14:00 [13097]


tambi | 19    2016-08-02 11:14:00 [13097]

Kedves Barátaim! A saját hülyeségem az őrületbe kerget:
Mach3-al akarok vezérelni CNCDRIVE-os rendszert, ami PRG01 stick-el beállított DG4S-16035 meghajtóból, és a rászerelt illetve stick-jével bele csatlakoztatott AMT103 encoderből áll. Azt gondolom, hogy a PID-et valamennyire sikerült behangolni, de egyébként bármit állítotok bárhova, Mach-3tól az encoder osztásig, nem tudom a motor fordulatszámát 2200ford/perc fölé emelni. Ha megpróbálom "gyorsabb" beállítással, akkor a DG4S-16035 hangoló csatlakozója mellett levő piros LED azonnal villogni kezd (felváltva a normál üzemet jelző zöld LED-el), és elveszi a motortól a feszültséget. Mit lehetne tenni???
Köszönettel; Tambi


Karácsony Sándor | 116    2016-08-01 09:40:00 [13096]

Elnézést a szóvicc miatt!!!
Talán a lépéstévesztés probléma behatárolásában segítene egy impulzus számláló.Arduinós vagy valami más egyszerű.

Előzmény: Kisamotors, 2016-07-30 23:07:00 [13092]


Szalai György | 6304    2016-08-01 06:11:00 [13095]

„miért ne mehetne 3000Rpm környékén”

Szögsebesség hatása a dinamikára?
Intenzív kopás?
Növekvő kefezaj?

Előzmény: Kisamotors, 2016-07-31 13:22:00 [13094]


Kisamotors | 517    2016-07-31 13:22:00 [13094]

Kösz a segítségeteket, délután futok még egy kört a beállításokkal, ha nem lesz megnyugtató és jelentős a változás, újravezetékelem az egészet.

50V, mert gondoltam ha már tudja, miért ne mehetne 3000Rpm környékén.
Viszont gyakorlatban nekem az 1000Rpm is bőven elegendő (5000mm/min).
tapasztalat szerint 3-4A áram is mindenre elég, dinamikusan mozog ezzel is.
Az encoder 512-es osztású.


kozo | 963    2016-07-31 08:08:00 [13093]

Az e240 motorral a határokat feszegeted , 50V sok amper ... encoder 1000es? Ha igen akkor ne erőltesd .
Kissebb motorokhoz inkább ajánlanám az SMCt 400-500 as encoderrel .

Az írt hibajelenség kábelezés ill. zavarra utal (akár a PC párhuzamos kábel föld stb miatt is , ne csak az encoder kábelt ellenőrizd , próbáld PC párhuzamos kábel nélkül , föld hurkokat se nagyon csinálj , motor kábel árnyékolás is fontos stb... ), ha kábelezést rendben érzed , akkor a 7414 IC step - dir - encoder kapukat kösd át , kicsi zavarokat is bebillenthet , stabil zavarmentes jel esetén nem kell az csak a kommunikációra .

Paraméterek :
P1 lehetne kicsit magasabb ha kell a fordulat
P1 P2 "aránya" , értéke sem nagyon tetszik lehet inkább fel kellene cserélni őket .
P3 kicsit soknak tűnik
P4 szerintem 240 elég kell legyen (320 at a terminal progi elvileg nem is enged)
P5 akár jó is lehet de ha mégsem találod el akkor sokat ront a működésen
P7 nagyon magas , én nem is nagyon használom , 1 -100 között is hatásos lehet.

(Megyek mert kihűl a Balaton ...)

Előzmény: Kisamotors, 2016-07-30 22:11:00 [13090]


Kisamotors | 517    2016-07-30 23:07:00 [13092]

Szkópolni akart lenni természetesen.

Én a gépépítés "öröme" miatt építek gépet, ha egyszer kész lesz, nem is tudom mit kezdek vele.
Na nem ezért haladok lassan, hanem folyamatosan ehhez hasonló szívásban vagyok.
1-2 hétig még elmegy, de ezzel már régen küzdök.

Épp az itt olvasottak miatt lett szervós, mert az szabályzott, sok tekintetben jobb, kontrolált rendszer.
Érdekelt a kihívás és a működése is, de most csak egy helyben topogok vele.
Biztos vagyok benne, hogy 2-3Nm-es lépetőkkel sokkal jobban járnék, legalábbis sokkal jobban bíznék bennük ezek után.
Értem én, hogy nagyon fapados vezérlő, de itt nem ez a gond.
Valami nálam nem stimmel, amit elvárnék a vezérléstől azt bőven túlteljesíteni még az SMC is.

Előzmény: Karácsony Sándor, 2016-07-30 22:47:00 [13091]


Karácsony Sándor | 116    2016-07-30 22:47:00 [13091]

Én is kacérkodtam az SMC servoval ,mert egyszerűnek néz ki .De, ha így kell "szópolni" vele mindig halogatom.

Előzmény: Kisamotors, 2016-07-30 22:11:00 [13090]


Kisamotors | 517    2016-07-30 22:11:00 [13090]

Ok, de mit tegyek?

Árnyékoljak, szópoljak, paraméterezzem újra?
Hol kezdjem?
Azért gyanakodom a paraméterekre, mert volt olyan beállításom is, ami stabilan és gyorsan működött, de kézzel mozgatva az orsót, oda-vissza, egyszer csak el tudtam tekerni 10-20-50 fokot is. Lengésbe jött és "darálva" el lehetett tekerni.

Ezekkel a paraméterekkel használom most:

P0 433
P1 730
P2 1240
P3 57
P4 320
P5 696
P6 256
P7 2273

Tápfesz 50V.

svejk | 24826    2016-07-30 21:56:00 [13089]

A mikrovezérló a hibás működést csak a bemenő step jelek és a motorról visszajövő encoder jelek arányából tudja megállapítani.

Ha ezen kívül akár a step jelek, de főként az encoder jelek fals értékek akkor a mikrovezérlő ezt próbálja korrigálni és ilyenkor lesznek az igazi tévesztések.

Tehát ez a két kör amit alaposan át kell tanulmányozni.
Hidd el a mikrovezérlő önmagában nem téveszt...

Előzmény: Kisamotors, 2016-07-30 21:47:00 [13087]


Kisamotors | 517    2016-07-30 21:53:00 [13088]

Még annyi, hogy jellemzően az X,Y-on nagy a tévesztés, a Z tengelyen, ahol lényegesen kisebb 10x3mm-es orsó van, 200mm hosszban, nagy sebességen, és gyorsuláson sem téveszt észrevehetően. Nem mértem órával, de 1-2 tizednél nem több, vagy nulla. Tudom ez is nagyon sok lenne, ha nem arról beszélnénk, hogy az X,Y meg két centi


Kisamotors | 517    2016-07-30 21:47:00 [13087]

Kösz, én használom, sajnos többet is, mint terveztem

Továbbra sem boldogulok a szervók "lépésvesztésével".
A 100 nanós kondi látszólag megoldotta a dolgokat, asztalon tökéletesnek tűnt.

Nem tudom hogy fogjak a hibafeltáráshoz. Sokszor kis sebességen (1000mm/min, 300 gyors.) , is lépést veszt.
Annak ellenére, hogy sokkal nagyobb sebességen 10x nagyobb gyorsuláson sem villannak be a sárga ledek. (5000mm/perc, 3000 gyorsulás).

SMC terminalból ennnél is vadabbul tud működni, majd leesik a gép az állványról, ilyenkor már villognak a hibajelző ledek.

Szóval mi annak az oka, hogy a képességei 10%-án járatom és mégis úgy veszt lépést, hogy nem veszi észre?

Stress teszttel 5000-es gyorsulással centiket képes volt arrébb mászni.


E240, 50V-ról megy, direktben hajt egy 1605-ös 400mm-es orsót.A mozgó tömeg olyan 20-25 kiló.
A táp egy 300W-os toroid, 2x10000uf, 100uf, 100nF szűréssel.
Encoder UTP kábelen megy a táp és a jel 1-1 csavart érpáron.

Tudnátok ezzel a jellemzőkkel bíró rendszerhez paramétereket adni kályhának? (P0-P7)

Attól tartok az én beállításaim elég vadak, bár látszólag teljesen jól működik.

Kösz!

Előzmény: kozo, 2016-07-26 07:46:00 [13086]


kozo | 963    2016-07-26 07:46:00 [13086]

Üdv Urak ...
Ha valaki használja az SMC servot és a terminal progimat akkor ...
Az oldalamra feltettem egy SMCterminal program frissítést . Nagy csodák nincsenek benne , inkább csak hiba javítások .

Megjegyzem mint az oldalamon is : csak az SMC1.2hex file használatával teljes a progi funkció skálája . A miértek az oldalon olvashatóak .


J-Steel | 163    2016-07-15 19:07:00 [13085]

Állandó mágneses motor = Szinkronmotor
(nem ideértve az egyenáramú motort aminek kommutátora van)


J-Steel | 163    2016-07-15 19:06:00 [13084]

Tisztelt Urak!

Adatlap? Jaj tudom.
Kor 30-as. Fogl. Villamosmérnök Tart. hely. Szeged

Wiki szerint a szinkron forgógép: Forgórészét egyenárammal táplált tekercseléssel, vagy állandómágnesekkel gerjesztik, állórészén többfázisú váltakozó áramú tekercselés található.

Sásdi Úrnak szeretném elmondani, hogy az utóbbi 30 évben a mérnökök azon vannak, hogy olyan elektronikát készítsenek, ami a szinkron motor forgórészének állása alapján adja rá az áramot a három bemenetre, így a motor mindig nyomaték alatt van. Ez a "jel" már változó frekvenciájú, illetve ha a forgórész áll, akkor nem is szinuszos. (szaknyelven elektronikus kommutáció)
A frekvenciaváltó onnan tudja, hogy hogy milyen szögben van a forgórész, hogy méri a három ág áramát, és matematikailag visszaszámítja.

Egyébként az a híre járja az állandó mágneses motoroknak, hogy a legeslegjobb a hatásfokuk, továbbá nagyságrendekkel nagyobb nyomatékot képesek leadni összehasonlítva egy azonos súlyú egyenáramú motorral. Sajnos az elterjedésének gátat szab, hogy az állandó mágnes (neodyum rudak) nagyon drágává teszik.

Előzmény: jani300, 2016-07-15 17:49:00 [13083]


jani300 | 5504    2016-07-15 17:49:00 [13083]

Érdekeseket írsz !
Kitöltöttebb adatlappal lehet kevesebbet bacogatnak

Előzmény: J-Steel, 2016-07-15 09:14:00 [13080]


jani300 | 5504    2016-07-15 17:43:00 [13082]

Üdv ! A szinkron motorokba is szoktak kalickát tenni a forgórészbe ,és így felpörög a szinkron fordulatszám közelébe , és csak szinkronba kell ugratni . Öreg lévén , én is tanultam valami ilyesmit
De gondolom nem erre gondolt a vezérlővel kapcsolatban . Ugye az AC szervó is szinkron motor és mégis ! Működik
De nem kötekedésként írom , csak a teljesebb kép kedvéért .

Előzmény: Sásdi Zoltán, 2016-07-15 16:10:00 [13081]


Sásdi Zoltán | 359    2016-07-15 16:10:00 [13081]

Én már öreg ember vagyok. Úgy tudom a szinkron motorok, kevés kivétellel(a marha kicsik és alacsony fordulatúak) nem indulnak csak úgy el, fel kell pörgetni a szinkronfordulatra.
Persze lehet, úgy vagyok mint az piás, aki minden nap kérdezi a doktort: ihatna-e egy stampedlivel. A nem válaszra, meg, hogy tegnap is kérdezte, azt mondta: Hátha fejlődött az orvostudomány.
Hát, hátha fejlődtek a szinkron motorok.

Előzmény: J-Steel, 2016-07-15 09:14:00 [13080]


J-Steel | 163    2016-07-15 09:14:00 [13080]

Tisztelt Urak!

Lenne egy olyan kérdésem, hogy ha építettem egy USB-s motorvezérlő rendszert - ahol meg tudok adni a(z aszinkron, szinkron) motornak nyomatékot, fordulatszámot vagy pozíciót, és ezt ő végrehajtja - a Mach 3 milyen lehetőségeket kínál, hogy összekapcsolódjak vele?
Tud erről valaki valamit? Köszönöm!


tambi | 19    2016-07-15 07:21:00 [13079]

Gátlástalanul rátelepítettem a MACH-ra, megjavult, és még az UC100 is működött. Köszi


tambi | 19    2016-07-15 05:51:00 [13078]

Köszi Pabló! Gondoltam rá, de ha minden PID-hangolásnál újra kell telepíteni a MACH-t, akkor szomorú leszek...
Derűs napot!

Előzmény: Pabló, 2016-07-14 17:51:00 [13076]


Kisamotors | 517    2016-07-14 21:16:00 [13077]

Helló!

Van egy Minertia (RM) szériás, 4 kefés 70W-os, 2000-es encoderes motorom. Biztos ismerős, felbukkant már a fórumon korábban ilyen.

Gondoltam másodjára is nekifutok, hogy összehagnoljam az SMC-vel, igazán most sem jártam sikerrel.
Igazat megvallva, már elsőre sem illeszkedtek a dolgok egymáshoz, de gondoltam paraméterezéssel talán meg tudom oldani.
2000-es encoder már sok lehet az SMC-nek,de Z tengelyen lenne, nem tervezek gyors mozgást.
Másik, hogy 50V-ról szeretném hajtani, ahogy az E240-eket, X,Y-on azok vannak.

Ennek a mocinak viszont teljesen más a specifikációja, különösen a V/Rpm érék.
50V-ról ez 10.000 Rpm fölött forogna.
Azért még így is sikerült összehoznom egy használható beállítást.
Viszont azt vettem észre, hogy nem túl nagy nyomatékkal el tudom fordítni a motor tengelyét úgy, hogy nem érzékei a vezérlő, nem állítja le hibajellel.
finoman mozgatva látszik a "szkópon" a hiba, de egy idő után állandósul, miközben a tengely elforgatható. Persze küzd ellene, az áram max. közelében van, a bajom az, hogy még a hibajelző sárga led sem jelez.

Nem is erőltetném a dolgot csak a gépen már a helyén van a motor, nem akarok új konzolt gyártani, mert nem pont ugyanaz a felogatása, mint az E240-nek.





Pabló | 1521    2016-07-14 17:51:00 [13076]

Lehet érdekes lenne machot újratelepíteni.
Hátha megoldja.

Előzmény: tambi, 2016-07-14 16:03:00 [13074]


tambi | 19    2016-07-14 16:05:00 [13075]

Bocs! Egyébként a motort nagyszerűen forgatja a MACH3...

tambi | 19    2016-07-14 16:03:00 [13074]

Kedves Barátaim! Elektron útmutatása alapján az eddig zörgő-csörgő DCM-400W DC szervómat DG4S-16035 meghajtóval sikerült beállítanom, csendes,sima járásúra. Most viszont a MACH-3 nem enged motortuningot. Minden más funkció működik, lehet állítgatni össze-vissza, de a motortuning nem gördül le. Ezen a szofverkikapcsolás, ki- és bekapcsolás, kihúzás, újraindítás, hangoló egység leválasztása, stb. stb sem segített. Mit lehetne itt tenni??? Köszönettel; Tambi


J-Steel | 163    2016-07-12 14:20:00 [13073]

Ez az encoder tárcsa gyártása dolog engem is érdekelne. Nekem 1200-as tárcsák kellenének.


svejk | 24826    2016-07-07 18:33:00 [13072]

Sajnos a 400-ast nem találom, csak az 500 -at és a 600-asat.

Előzmény: svejk, 2016-07-07 12:06:00 [13069]


Amatőr | 2045    2016-07-07 16:57:00 [13071]

Ez is egy működő program.

Előzmény: atideath, 2016-07-06 08:26:00 [13063]


szf | 1357    2016-07-07 16:13:00 [13070]

Küld egy emailt,hogy vàlaszolni tudjak.Nem tudok ide képet feltenni a telóról.

Előzmény: atideath, 2016-07-07 10:54:00 [13068]


svejk | 24826    2016-07-07 12:06:00 [13069]

estére elküldöm, corel-ban rajzoltam

Előzmény: atideath, 2016-07-07 08:30:00 [13066]


atideath | 575    2016-07-07 10:54:00 [13068]

Az utóbbiról esetleg nem tudsz egy képet mutatni? Azt nem nagyon értem egyenlőre. A menetes orsó végére lenne lehetőség felszerelni az encodert de akkor ott még esztergáltatni kellene. Azt meg nem szeretném, jobban örülnék ha valamilyen módon fel tudnám szerelni a motorra az encodert csak teszt kedvéért is.

Előzmény: szf, 2016-07-07 09:23:00 [13067]


szf | 1357    2016-07-07 09:23:00 [13067]

Szia!
Én annak idején hasonló problémával küzdöttem mint te.Egyik esetben a motor által meghajtott tengely túlsó végére szereltem fel az encodert a másik alkalommal pedig egy encoder tárcsát közvetlenül a tengelykapcsoló, motor felőli oldalára raktam fel (böszme nagy lyuk volt rajta ).Mindegyik a mai napig működik. De, ha szétszedsz egy tintasugaras nyomtatót ott is külön van az encoder tárcsa meg a DC motor.

Előzmény: atideath, 2016-07-07 08:30:00 [13066]


atideath | 575    2016-07-07 08:30:00 [13066]

Hát sajnos nekem is egyenlőre álom az ipari vezérlő és szervó hajtás ezért szeretném azokból megcsinálni amiket itthon találok. Esetleg nem tudnál privátba küldeni egy jó tárcsa tervet a Q98xx-hez? Amit csak elrohanok a nyomdába és megcsinálnak? Jobban hagyatkoznék arra ami már működik. Másik opció volt hogy rendelek Aliról olyan encodert amit linkeltem csak azzal az a baj hogy nem egyszerű összehozni a motorokkal.

Előzmény: svejk, 2016-07-06 20:12:00 [13065]


svejk | 24826    2016-07-06 20:12:00 [13065]

Átm. 22 mm-es 400-as tárcsát a nyomdai előkészítők simán levilágítják filmre.
Ez pont jó a 150 LPI-s Q98xx-ekhez.
A film elég vastag ahhoz, hogy egy kis aggyal ekkora átmérőn megfelelően merev legyen.

Ma már azt mondom jó játék volt, akkoriban azonban több hobby gépre is felkerült.
(az ipari servo még csak álom volt abban az időben számomra)

Előzmény: Kisamotors, 2016-07-06 19:19:00 [13064]


Kisamotors | 517    2016-07-06 19:19:00 [13064]

Vajon mennyire kivitelezhető egy százasnál nagyobb osztású tárcsa?
Olyat pedig 3 dolcsiért találsz az eBay-en, optoval együtt. Más kérdés, hogy ilyen kis felbontású encoderrel DC hajtást építeni...

Előzmény: atideath, 2016-07-06 06:48:00 [13062]


atideath | 575    2016-07-06 08:26:00 [13063]

Nincs meg valakinek a SquireTech által készített encodertárcsa tervező program? Meg tudná esetleg valaki osztani? Nem találom sajnos sehol.


atideath | 575    2016-07-06 06:48:00 [13062]

Hát jelenleg semmi nincs a motorok végén. Még tengelycsonk se amire rá lehetne tenni az encodert, ezért gondolkodom a kínai encoderen. Van itthon nekem vagy 3db Q9874 de ezekhez meg nincs kódtárcsa. Bár megpróbálhatok csinálni. Amit küldtem encoderrel meg az a baj hogy nem tudom hogy kellene felfogatni a motorra.

Előzmény: Kisamotors, 2016-07-05 19:25:00 [13061]


Kisamotors | 517    2016-07-05 19:25:00 [13061]

A HEDS elsősorban annyival tud többet, hogy már ott van a motor végén, ill. csak rá kell csavarozni
Ez pedig rá kell faragni, tengelykötés, közdarab, távtartó...stb. Egyébként biztason működik vele, kicsit kisebb felbontású, de ez SMC-hez akár még előny is lehet.

Előzmény: atideath, 2016-07-05 18:21:00 [13060]


atideath | 575    2016-07-05 18:21:00 [13060]

Valaki használt már vagy próbált ilyen encodert-t SMC vezérlővel? Encoder

Elég elfogadható áron van és nem kell akkor mókolni más encoderrel. Vagy mivel tudnak többet a HEDS encoderek?

Kisamotors | 517    2016-07-02 23:06:00 [13059]

Beállítás alatt én egy másik E240-et fogattam rá kuplunggal. Mikor már nagyjából elégedett voltam, tettem rá 20W-nyi izzót is a dinamóként működő motorra.
Biztos van még mit finomítani rajta, bár ott tartanék!
Összeáll lassan a PC-s vezérlés is, felemeltem a kernel frekit 100kHz-re, így már csak 4000mm/min felett akad, az alatt harmonikusan mozog.
Egyelőre jó lesz, úgy sem terveztem 3000 feletti sebességet.
A Mach beállításainak sok helyen utána néztem, bár kevés dolog ragad meg bennem, túl sok input, de az exact stop/cont.vel. dologra már Zozo is felhívta a figyelmem.

A notim, nem mai darab, de elég erős vas, két magos valami, seder rajta a win7
Itt olvastam, hogy sok noti LPT portja "furán" működik, lehet itt is ez van.

Csak tesztelésre használtam, mert így is sok a drót, nem akartam még hozzá pc-t, monitort, bill.-t, egeret előszedni.

Gépállványt is meg kellene már csinálnom, lenne helye a PC-nek. Na meg ezer dolgot...
Kösz a segítséget!


svejk | 24826    2016-07-02 10:33:00 [13058]

Csak általánosságokat tudok mondani.
A servo a mechanikán mindig másképp viselkedik mint terhelés nélkül.
Általában a mechanikával is be kell állítani a PID-et.
(én anno az asztali tesztek alkalmával mindig felfogattam a motortengelyre egy kézi fúrógép tokmányát, ez hivatott utánozni a mechanika tehetetlenségét)
Az exact stop--constans velocity (G61-G64) beállítás is megkavarhatja rendesen a dolgot, főleg a teszt fázisokban.
Természetesen a notid is lehet a gyenge pont, de egy fórumtársunk nemrég valami ilyesmit írt, hogy tiszteljük meg a szoftver fejlesztőit, hogy rendes vason futtatjuk a programot.

Előzmény: Kisamotors, 2016-07-01 21:55:00 [13057]


Kisamotors | 517    2016-07-01 21:55:00 [13057]

Kösz a gyors reagálást, ezt megtaláltam viszont most, sokadjára átnézve látom hogy, tényleg ott van a Ke (V/RPM) érték is...
Legalább nem tévedtem nagyot, 14V körül forog 1000 Rpm-el.

Időközben beüzelemtem a motorokat, szerintem sikerült jól beállítani az itthoni PC-n.
Felszereltem a gépre, a műhelyben egy notival vezérlem.
Kézi vezérléssel szépen fut, de ahogy elindítok egy Gkódot jó nagyokat ránt a mechanikán.
először azt hittem valami megszorul egy pillanatra, de a motorok áthúzzák rajta. Sokáig kerestem mi akad, mi szorul, de a mortorokat leszerelve láttam a motorok okozzák a durva ütésszerű hibát.
Pár század, tized másodpercre, mintha megállnának, vagy hirtelen (ütés szerűen) leesne a szögsebessége indokolatlanul. Véletlenszrű, de ismétlődő dolog, a fordulat/gyorsulás növelésével durvább.
Ebben a melegben nem volt kedvem a drótmalacot szkópolni, van esetleg valami mentő ötleted, mint legutóbb?
Notebookra gyanakszom, mert csak az változott a konfigban, PC-ről jól ment. A Mach3 beállításai persze azonosak.

Előzmény: svejk, 2016-07-01 21:34:00 [13056]


svejk | 24826    2016-07-01 21:34:00 [13056]

A kékkel kiemelt rész vonatkozik az E240-esre.

Előzmény: Kisamotors, 2016-07-01 21:17:00 [13054]


Rabb Ferenc | 2888    2016-07-01 21:33:00 [13055]

G240 (E240) adatlap

Előzmény: atideath, 2016-07-01 14:00:00 [13050]


Fórum főoldal  |  A lap tetejére

Időrend:
Oldal 3 / 261 Ugrás ide:
|◄ Első  ◄ Előző  1 2 3  4   5   6   7     Következő ►  Utolsó ►|