HobbyCNC fórum
  v0.9.1 alpha

Fórum betekintő Fórum címe: http://forum.hobbycnc.hu



CNC USB controller, (Planet CNC)

Egy kedvező árú USB-s szoftver és hardver


Időrend:
Oldal 4 / 23 Ugrás ide:
|◄ Első  ◄ Előző  1 2 3 4  5   6   7   8     Következő ►  Utolsó ►|

Fórum főoldal  |  A lap aljára

exup | 310    2016-03-03 21:07:00 [953]

Kb 1000ft ebay-en egy arduino nano. Annak kell 5v. MkI egyik digitális kimenetére rákötöd. Az az orsó fordulatszám változtatással, ami g-kódban S paraméter, kiad 0 és 1470hz közötti jelet. Az arduino nano pedig ennek fügvényében ad ki 0-5v pwm jelet a lézerre. Az inkscape progihoz meg van plugin, amivel képet átalakít s paraméterezett g-kódra. Az arduino nano programkódja fent van planetcnc forumán. Nekem ez így tökéletesen fut. 2 hibàm van már csak. Az mkI pl nem tud akármennyi utasítást végrehajtani rövid idő alatt. Az egyik képem 1000-es sebességgel nem fut végig. Buffer hibával befagy. Ezt orvosoltam lassabb F paraméterrel. A másik nagyobb gondom, hogy egy nagyobb g-kódot out of memory-val kidob. Sajnos a tabletemben csak 2giga ram van.

Előzmény: guliver83, 2016-03-03 15:38:00 [952]


guliver83 | 2340    2016-03-03 15:38:00 [952]

Végül rájöttem én is mi a megoldás rá!
Köszönöm a válaszodat!

Előzmény: sanyi, 2016-03-03 08:09:00 [951]


sanyi | 1230    2016-03-03 08:09:00 [951]

Miért nem lehet így gravírozni? Mi a különbség?
Mivel lézer esetében gyakorlatilag csak két szín van ezért ha 1 bitesre van konvertálva a kép akkor pontosan elegendő. Az árnyalatokat ilyen esetben valamilyen más algoritmussal (error diffusios eljárással alakítják ki pl. ebből a leg elterjedtebb Floyd-Steinberg). Ebben az esetben ponotsan elegendő a két teljesítményszint. A lézer teljesítményt csak egyszer kell beállíteni, hogy mi legyen a maximum az adott anyaghoz amivel megfelelő minőség érhető el adott sebesség mellett.
Mivel az USB-CNC csak egy 0 és néhány kHz közötti frekvenciájú jelet tud kiadni ezért ezt egy segéd áramkörrel kell PWM jellé alakítani vagy ha 0-10V jelet vár az eszköz akkor olyanra alakítani. Esetleg lehet használni a modelező vezérlőkhöz kialakított jelet is mert olyat is tud. Pl. egy BL modelezős motort képes meghajtani mert úgy is be lehet állítani.
Közös mindhárom megoldásban, hogy kell valamilyen kiegészítő áramkör hozzá.

Előzmény: guliver83, 2016-03-02 23:16:00 [950]


guliver83 | 2340    2016-03-02 23:16:00 [950]

Most ha egy lézert akarok használni azt hogy tudom megvezérelni vele?
Azt meg tudom vele csinálni, hogy be és ki kapcsolja például úgy mint egy főorsót pancsolgatna ez elég is arra, hogy egy kontúrvágást csinálni vele, de ha valami fotót akarok gravírozni azt már így nem lehet. Van valami megoldás rá?

Előzmény: sanyi, 2016-03-02 22:38:00 [949]


sanyi | 1230    2016-03-02 22:38:00 [949]

Alapból nincs PWM kimenete, de olyan van , hogy a kimeneten a jel frekvenicáját változtatja.

Előzmény: guliver83, 2016-03-02 20:09:00 [947]

órafaragó | 278    2016-03-02 22:38:00 [948]

A fordulatszám vezérlést az MK1 alapból is tudja.

Előzmény: kaqkk007, 2016-03-02 18:49:00 [946]


guliver83 | 2340    2016-03-02 20:09:00 [947]

Na most hogy lehet az Mk1 PWM kimenete?
Ha maga a program nem tudja, vagyis nincs engedélyezve szerintem.
Mk2-3-4 már tudja ezt

Előzmény: kaqkk007, 2016-03-02 18:49:00 [946]


kaqkk007 | 745    2016-03-02 18:49:00 [946]

Nekem a kínai verziója van az MK1 nek azon van egy külön panelka ami 0-10v os jelet ad a főorsó fordulatának vezérléséhez , ezt fel lehetne használni a lézer "villogtatására"?

Előzmény: exup, 2016-03-01 23:10:00 [945]


exup | 310    2016-03-01 23:10:00 [945]

Írtam már...a hiba a közelség volt. Mivel a pic és a relé a dobozfedőben van, trafó a dobozban, ezért nem tudom melyik utálja a trafót, de fedél levéve és tökéletes. Pwm jelet pedig az egyik kimenetről csinálom arduino nano-val. Mivel az mk1 nem tud pwm-et.

Előzmény: kaqkk007, 2016-03-01 21:48:00 [944]


kaqkk007 | 745    2016-03-01 21:48:00 [944]

A lézert a PWM kimenetről vezérled ?

Előzmény: exup, 2016-03-01 21:43:00 [942]


kaqkk007 | 745    2016-03-01 21:47:00 [943]

A végén mi volt a hiba ? Hogy tudjuk ha valaki más is belefut ..


exup | 310    2016-03-01 21:43:00 [942]

Köszi...most már így fullosan működik. Még a lézerrel bénázok. Már nagyon jól szuperál a pwm vezérlés csak különböző anyagoknàl más teljesítménnyel kell égetni. Pontosan még nem tudom mekkoràk ezek és az üveg, csempe felület előkezelését.

Előzmény: kaqkk007, 2016-02-28 16:50:00 [941]


kaqkk007 | 745    2016-02-28 16:50:00 [941]

Van eladó 22v os ha kell....


exup | 310    2016-02-27 22:43:00 [940]

Nekem nem toroid trafóm van.

Előzmény: kaqkk007, 2016-02-24 18:53:00 [939]


kaqkk007 | 745    2016-02-24 18:53:00 [939]

Nálam így működik teljesen hibamentesen. nincs 20cm ...

Előzmény: exup, 2016-02-23 19:28:00 [938]

exup | 310    2016-02-23 19:28:00 [938]

Ha a pic és a relé távol van a 230/24V trafótól, akkor nem fagy le az usb kapcsolat. Most kb 20centire van és 1 centire voltak. Úgy a tésztaszűrő se segített


exup | 310    2016-02-22 21:57:00 [937]

Igen csak a vezérlőnél van földre kötve. de már tovább teszteltem. Beraktam egy optocsatolót még a kimenet közé, de nem segített. Közbe valószínű, hogy a 230/24V trafó miatt van. Én SLA7062-es vezérlőket használok. Ha lekötöm róla a step/dir jeleket és a tápot is, akkor is lefagy. Tehát ha csak a 230/24V trafó áramot kap, akkor már lefagy az usb, ha a relét kapcsolgatom a kimeneten. Mivel a relé,pic,trafó is egy dobozban van nagyon közel, ezért a héten szétszedem és áthelyezgetem őket. Majd jelzem mi a vége.

Előzmény: kaqkk007, 2016-02-22 18:43:00 [933]


kaqkk007 | 745    2016-02-22 20:59:00 [936]

Én tb6560 al indítottam a gépemet, de miután 2 elszállt váltottam tb6600 ra .

Előzmény: batesz, 2016-02-22 20:37:00 [935]


batesz | 302    2016-02-22 20:37:00 [935]

Milyen motormeghajtót használtok?
Nekem a DVR8825 valahogy nem vált be, nem stabil, folyamatosan lépést veszít vele a motor.
A4988 tökletesen működik.


kaqkk007 | 745    2016-02-22 19:08:00 [934]

Egyébként az is előfordulhat hogy a motoráram és a mikrolépés van rosszul beállítva, nálam előfordult hogy nagy áramra állítva 32 es mikrolépésnél a motormeghajtó letiltott (gondolom túlmelegedett) most 1/8 on és 2,8A árammal tőkéletes

Előzmény: exup, 2016-02-21 20:13:00 [932]


kaqkk007 | 745    2016-02-22 18:43:00 [933]

Az árnyékolást ugye csak a vezérlőnél kötötted gnd-re , a motornál nem testelted ?

Előzmény: exup, 2016-02-21 20:13:00 [932]


exup | 310    2016-02-21 20:13:00 [932]

Nem segített...másik dolgot csinálok vele


exup | 310    2016-02-19 06:25:00 [931]

Oksi. Jelzek, ha tovább jutottam

Előzmény: kaqkk007, 2016-02-19 05:49:00 [930]


kaqkk007 | 745    2016-02-19 05:49:00 [930]

Először cseréld le a motorok vezetékét árnyékoltra, aztán ha még meglesz a hiba tovább keresgélünk


exup | 310    2016-02-18 23:05:00 [929]

A másik épp semmin sincs...ugyanis a dugaljba nincs semmi dugva lézer esetén. De ne ilyeneken okoskodjatok. órafaragó...láttál már épületgépészeti elektromos szekrény rajzot? Ott egy 4 morzés relén simán van 230..24..meg bármi más együtt. Semmi köze az érintésvédelemhez.

Előzmény: tóthz, 2016-02-18 20:25:00 [927]


órafaragó | 278    2016-02-18 20:37:00 [928]

Teljesen mindegy, mindenhol tiltott a hálózati villany és a gyenge villany közös relével kapcsolása. Érintésvédelem felrúgása az egész.

Előzmény: tóthz, 2016-02-18 20:25:00 [927]


tóthz | 493    2016-02-18 20:25:00 [927]

"Mellesleg akár a 230 nullája is lehet kapcsolva."

Lehet, de ha bontó állásban van a jelfogórugó akkor az egyik pogácsa nullán, a másik 230-on van...

Előzmény: exup, 2016-02-18 15:48:00 [925]


órafaragó | 278    2016-02-18 18:35:00 [926]

Két különböző feszülrségszint közel egymáshoz nem egészséges.
Tegyél bele két relét és nincs vele gond.
Egyszer ad az 5V-ra egy pofont és kifekszik mint a béka.

Előzmény: exup, 2016-02-18 15:48:00 [925]


exup | 310    2016-02-18 15:48:00 [925]

Mibe hal bele? Én ezt nem gondolom így. 230-on nem folyik áram olyankor. Mellesleg akár a 230 nullája is lehet kapcsolva. De azért köszi a figyelmeztetést.

Előzmény: órafaragó, 2016-02-18 14:55:00 [924]


órafaragó | 278    2016-02-18 14:55:00 [924]

Az 5V-os kör előbb utóbb belehal!

Előzmény: exup, 2016-02-18 14:31:00 [923]

exup | 310    2016-02-18 14:31:00 [923]

Igen.

Előzmény: órafaragó, 2016-02-18 14:16:00 [922]


órafaragó | 278    2016-02-18 14:16:00 [922]

Egy relével kapcsolsz 230-at is meg 5V-ot is????

Előzmény: exup, 2016-02-18 07:40:00 [921]


exup | 310    2016-02-18 07:40:00 [921]

Kondi az nincs, de akkor azzal kipróbálom. Relé két dolgot kapcsol. 230v-os dugaljra ad tápot a marónak másik érintkezőn 0-5v-ot a lézernek. Épp melyiket használom. Mindkettőhöz tegyek?

Előzmény: kaqkk007, 2016-02-18 06:00:00 [920]


kaqkk007 | 745    2016-02-18 06:00:00 [920]

Egy kérdés : a pic kimenetén amire a relét kapcsold van dióda az induktív "visszerúgás"levezetésére ? Ha igen akkor a relé kapcsoló érintkezői közé tegyél egy 100n -s kondit .


kaqkk007 | 745    2016-02-18 05:56:00 [919]

Erre a képre gondoltam


exup | 310    2016-02-18 00:17:00 [918]

Akad ott pár kép. Ugyan az említettet nem lelem, de nem is olyan lényeges. Most az egyik do rámegy nekem egy arduino nano-ra, ami a spindle jelekből pwm jelet csinál a lézer teljesítménynek. Egy másik meg a lézert ki-be kapcsolja. De kép égetésnél a sorok végén kikapcsol, majd új sornál bekapcsol a lézer a relével...ilyenkor fagy meg, amikor épp kedve van. Ha csak pl vágás elején kapcsol csak be és végén ki, akkor minden okés...vagy, ha a léptetők nem kapnak tápot, akkor a gyors ki-be kapcsolás nem zavarja az usb komunikációt.

Előzmény: kaqkk007, 2016-02-17 19:35:00 [917]


kaqkk007 | 745    2016-02-17 19:35:00 [917]

Az oldalamon találsz képeket a "kábelrengetegről"

Előzmény: exup, 2016-02-17 19:29:00 [915]


kaqkk007 | 745    2016-02-17 19:32:00 [916]

A főorsót programból indítom egy kísérletező panelra forrasztott nyákrelével ami csak a levegőben lóg a "drótokon" az az "áramirány" nem árnyékolt


exup | 310    2016-02-17 19:29:00 [915]

Neked van a három do-ból használva? Ha arról nem kapcsolgatok relét vagy, ha a motoroknak nem adok tápot, akkor nem fagy meg. De a relé is kell meg a motoroknak is kéne forogni....igaz nem árnyékolt a vezetékük.

Előzmény: kaqkk007, 2016-02-17 19:22:00 [913]


órafaragó | 278    2016-02-17 19:23:00 [914]

Ez a topik is arra indult csak mindig volt valaki aki belekötött meg fikázta mert neki nem tetszett és ezért inkább nincs publikálva semmi.

Előzmény: guliver83, 2016-02-16 22:57:00 [910]


kaqkk007 | 745    2016-02-17 19:22:00 [913]

Nálam csak a steppermotorok vezetéke árnyékolt a vezérlő felől van testelve az árnyékolás semmi ilyen problémával nem találkoztam .

Előzmény: exup, 2016-02-16 23:00:00 [911]


kaqkk007 | 745    2016-02-17 19:04:00 [912]

Én kb 2 éve használom , most gyűjtögetem az alkatrészeket a második gépemhez azon is ő lesz az "agy" Egy jó barátom javaslatára választottam ezt a vezérlőt és nem bántam meg , eddig csak mechanikai probléma volt a gépemen elektronikai nem .


exup | 310    2016-02-16 23:00:00 [911]

Rákötöttem az arduino nano-t az MKI-re és pwm jellel lézereztem. Sajnos szívok usb-n néha valami zavarral, mert eldobja egy pillanatra a komunikációt a tabletről. Korábban is csinálta, de segített a táp körbe egy EMI filter. Telekéne dobálnom ferrittel a kábeleket?


guliver83 | 2340    2016-02-16 22:57:00 [910]

Elég sokan használják azért az Mk1 verziót is csak nem írnak róla itt a fórumon és kitűnően megy nincs vele semmi gond.
Biztos van jobb meg drágább vezérlő is.


KBalázs | 1350    2016-02-16 14:08:00 [909]

Írtam volna hogy használnám?

Előzmény: órafaragó, 2016-02-16 14:05:00 [907]

KBalázs | 1350    2016-02-16 14:07:00 [908]

Aha.
Ez a GRBL egy 500 Ft-s Arduino Nano-n (vagy UNO-n) elfut, 30KHz stepfrekit tud, és GPL, azaz ingyenes, és van persze egy jópár szintén ingyenes progi ami küldi neki az adatokat (maga az eszköz G-kódot fogad). Legalábbis ezt találtam róla, még nem próbáltam, de majd fogom, minden van hozzá itthon.

Előzmény: sanyi, 2016-02-16 13:56:00 [906]


órafaragó | 278    2016-02-16 14:05:00 [907]

Senki nem kötelez rá, hogy használd.

Előzmény: KBalázs, 2016-02-16 13:43:00 [905]


sanyi | 1230    2016-02-16 13:56:00 [906]

Az USB-CNC Mk 1 nem tud 25KHz léptetőfrekit. Ezt még az elején kiderítettük. Gyakorlatilag 13 KHz-kürül megy maximum. Az Mk1 olyan sokat nem fejlődött persze kérdés, hogy a Kínai mikor verziót másolt.
Egyébként 70Euro a szoftver. Szerintem ez nem olyan sok, hogy ne lehetne kifizetni. A demo 25 sort játszik csak le a G-kódból, ez arra elegendő lehet, hogy eldöntse valaki, hogy jó lesz-e vagy sem.

Előzmény: KBalázs, 2016-02-16 13:43:00 [905]


KBalázs | 1350    2016-02-16 13:43:00 [905]

Azt írja a linken hogy 25KHz a step freki max. miben tud ez többet mint a pici Arduinoval felepíthetô usb cnc kontrollerek (GRBL)? Egyiket sem ismerem közelebbrôl.


órafaragó | 278    2016-02-16 13:21:00 [904]

Nézz utána a szlovén honlapján!
Minden le van írva amit változtatott.

Előzmény: guliver83, 2016-02-16 10:44:00 [903]


Fórum főoldal  |  A lap tetejére

Időrend:
Oldal 4 / 23 Ugrás ide:
|◄ Első  ◄ Előző  1 2 3 4  5   6   7   8     Következő ►  Utolsó ►|