HobbyCNC fórum
  v0.9.3.4

Fórum betekintő Fórum címe: http://forum.hobbycnc.hu



CNC USB controller, (Planet CNC)

Egy kedvező árú USB-s szoftver és hardver


Időrend:
Oldal 3 / 23 Ugrás ide:
|◄ Első  ◄ Előző  1 2 3  4   5   6   7     Következő ►  Utolsó ►|

Fórum főoldal  |  A lap aljára

RJancsi | 1269    2016-06-08 16:43:00 [1023]

Szia! Köszi az ötletet, de a SYMLY által javasolt Inkscape-t elég jól ismerem, megpróbálom ezt a plugin-os dolgot.

Előzmény: sunraw, 2016-06-08 15:17:00 [1021]


SYMLY | 373    2016-06-08 15:33:00 [1022]

Sok mindennel csinálhatsz.

Vectric: Cut2D, Vcarve, Aspire (ezekhez való postprocit linkeltem a laser topicba)

Inkscape +

Laser plugin

Ez utóbbi ingyenes

Előzmény: RJancsi, 2016-06-08 09:00:00 [1020]


sunraw | 1127    2016-06-08 15:17:00 [1021]

Szia!
Ami nálam bevált módszer - igaz sufnis - hogy a választott vonalrajzot, előbb elkészítem betűnek. Így tetszés szerint változtatható a mérete. Majd a Cambam progiban, az elrendezés és a paraméterezés után, készítek vele pályát és kódot.
Amennyiben kérdésed lenne, keress bátran, ha tudok, segítek.

Előzmény: RJancsi, 2016-06-08 09:00:00 [1020]


RJancsi | 1269    2016-06-08 09:00:00 [1020]

Sziasztok! Még mindig csak ismerkedek az 1W-os kék lézer lehetőségeivel.
Ti mivel (milyen programmal) csináltok fekete-fehér "vonalas" rajzból (bmp vagy jpg) vágásra alkalmas g-kódot? Tehát nem raszteres égetős, hanem vektoros állományt. A CNC USB kontroller program ugyan felkínálja a 2D kép importálását, de "outline" módban a legvékonyabb vonalakból is két párhuzamost generál, "centerline"-ban meg kiszámíthatatlan, hogy mit mivel köt össze. Az sem lenne baj, ha nem fizetős program lenne.


sunraw | 1127    2016-06-07 10:57:00 [1019]



Nos. 70x100mm, 600mm/m, 0,18mm sorköz. 80perc.
A fehér foltok napsugarak.

A kód a 3dp-s progival lett generálva.

Előzmény: sunraw, 2016-06-05 18:46:00 [1009]

kaqkk007 | 907    2016-06-06 21:45:00 [1018]

Próbáld a G30 at


Sásdi Zoltán | 387    2016-06-06 17:07:00 [1017]

Enter az M30 után?

Előzmény: Práger Mihály, 2016-06-06 16:55:00 [1016]


Práger Mihály | 120    2016-06-06 16:55:00 [1016]

Bocs én voltam a béna, nem jól állítottam be
a három kimenetet a progiban,úgyhogy működik
mindhárom.
Most már csak egy kérdés maradt az M30-as kódot
nem hajtsa végre.(ugrás a program elejére)
Megjegyzem lehet, hogy a programban van a hiba, de a Mach3-ban ugyanennél megcsinálja.

Előzmény: kaqkk007, 2016-06-05 19:14:00 [1010]


órafaragó | 278    2016-06-06 16:27:00 [1015]

File-settings-axis-axis SPU calibration

Minden tengelyt külön lehet kalibrálni és nem kell kínlódni vele.

Előzmény: kaqkk007, 2016-06-06 06:35:00 [1014]


kaqkk007 | 907    2016-06-06 06:35:00 [1014]

Hol található az a segéd ? Én mindig számított értéket állítottam , de ha van lehetőség pontosításra ...

Előzmény: órafaragó, 2016-06-05 22:51:00 [1013]


órafaragó | 278    2016-06-05 22:51:00 [1013]

Van a programban egy beállítási segéd, amivel pontosítani lehet a lépés beállítását.
Mérni kell távolságot és adott távra elküldeni a tengelyt.
Kiszámolja, sőt be is állítja a megfelelő értéket, hogy pontos legyen a mozgása.

Előzmény: Práger Mihály, 2016-06-05 17:49:00 [1006]


órafaragó | 278    2016-06-05 22:48:00 [1012]

Ebben a topikban 999.
Olvass vissza.

Előzmény: SYMLY, 2016-06-05 21:59:00 [1011]


SYMLY | 373    2016-06-05 21:59:00 [1011]

Erröl bővebben:
- milyen arduinos
- mikyen lézer
- hogy hoztad össze az arduinot a lézer vezérlővel
- ....

A laser topicba Köszi

Előzmény: sunraw, 2016-06-05 18:46:00 [1009]


kaqkk007 | 907    2016-06-05 19:14:00 [1010]

Nálam mindhárom kimenet rendeltetésszerűen működik 1főorsó-2hűtés-3hűtés elárasztással

Előzmény: Práger Mihály, 2016-06-05 17:49:00 [1006]


sunraw | 1127    2016-06-05 18:46:00 [1009]

Próbálkoztam végre az Arduino-s PWM mókával, íme:

kaqkk007 | 907    2016-06-05 18:25:00 [1008]

Az 533 as beállítás itt is jó .


kaqkk007 | 907    2016-06-05 18:07:00 [1007]

Sajnos most nem tudok utánanézni a válaszoknak , szanaszét van minden a garázsban majd ha a konyhafelújítás befejeződik és rendet rakok ,újraindul a cncusb ..


Práger Mihály | 120    2016-06-05 17:49:00 [1006]

Azért lenne még egy-két kérdésem mert csak most
kezdek a programmal ismerkedni.
Az egyik, hogy a vezérlőm 1600 mikrólépésre van állítva a gépemen, az orsó menetemelkedés 3mm,
így 533 van a Mach3-ba beállítva, ez a lépés/mértékegységnél ide is jó?
A másik, hogy a futó programban az M30-at nem csinálja meg, vagyis nem megy az elejére a program.Az M5 motor leállís sorba sem ugrik de ezt megcsinálja.
A harmadik kérdésem, hogy a Output3 (M7) működik ezen ? ez a hűtés. Az Output 1 (M3) és az Output2 (M8)az működik.
A Spindle & Coolant menüben be van állítva rá a 3-as kimenet de a programon az ikonra kattintva nem reagál.
Invertáltam a kimenet menüben akkor kigyullad a led de a programból nem lehet kapcsoltatni.

(M8) működik


kaqkk007 | 907    2016-06-04 22:24:00 [1005]

Én először amikor munkára fogtam az MK1-et beállítottam a potit és el is felejtettem miért lóg ott a dróton! Most hogy olvasom a hozzászólásodat jutott eszembe hogy a barátomnak ezt még nem mondtam el a vezérlőről!

Előzmény: Práger Mihály, 2016-06-04 18:01:00 [1003]


kaqkk007 | 907    2016-06-04 22:21:00 [1004]

Ez a tanulási folyamat része ! Úgy jó ha magadtól jössz rá a vezérlő használatának "finomságaira" Ha más elmondja nem biztos hogy minden részlet megmarad , de ha te megtapasztaltad akkor .....


Práger Mihály | 120    2016-06-04 18:01:00 [1003]

Úgy látszik az kellett, hogy írjak ide mert azután, hogy kiírtam ide öt perc után rájöttem.
Lényeg, hogy a manuális mozgatáskor már nem lehet
a potival sebességet állítani csak elötte, vagyis nyomva tartott gomb setén nem változik a sebesség.
Azért írtam le hátha valaki aki először építi meg
szintén szív vele.


Práger Mihály | 120    2016-06-04 17:42:00 [1002]

Üdv mindenkinek!
Építettem egy Mk1-est, de a poti funkciójára
eddig nem jöttem rá.A leírásban az van ,hogy a jog sebbességét lehet vele állítani , nálam nem csinál semmit.A csúszkáján tekergetésre megjelenik a változó feszültség, de a programban nem veszem észre, hogy valamire is hatással lenne.
Hozzáteszem, lehet, hogy a programban valamit nem jól állítok be.
Megköszönném ha megosztaná velem aki ezt tudja.


kaqkk007 | 907    2016-05-26 17:23:00 [1001]

A szabályzó kimenettel kösd sorba a főorsó relét ami a panelon van és avval kapcsoltasd ha jól emlékszem az M3-M4_M5 kódok valamelyike használható a kapcsoltatásra ...

Előzmény: sunraw, 2016-05-26 13:20:00 [999]


PSoft | 10037    2016-05-26 16:25:00 [1000]


"... a PicoLaser áramgenerátornak meg csak egy db optokapus bemenete van amivel a készenléti és a munkaáram között lehet váltani."

Az igaz, hogy csak egy db.optokapus bemenete van, de...
Az a bemenet, nem csak ki(0v) és be(+5V)-ot "tud".
Nem csak ki/be kapcsolgatja a lézert.
A 0-5V-os tartományon belül, szabályozza a kimenetet, a dióda teljesítményét.
Sokat használtam, a Mach-3 beépülő lézer pluginjával, ami PWM kimenet a Mach-ban.
Tökéletesen működött, a nálad levő 1W-os Pico-laser áramgenerátora is PWM-el vezérelve az optót.

Ha itt nézelődsz kicsit, ezek mind a Pico-Laser PWM-es vezérlésével készültek Mach-ból.
Ha vektoros rajzolásnál(ki/be) soknak ítélnéd a lézer teljesítményét, a legegyszerűbben, egy pártíz KOhmos poti sorbakötésével csökkentheted az optora jutó 5V-ot.
Nem csak ki/be kapcsolni tud az opto, van "köztes állapot" is.

Előzmény: RJancsi, 2016-05-25 23:54:00 [996]


sunraw | 1127    2016-05-26 13:20:00 [999]

Sziasztok!
Exup jóvoltából kaptam egy Arduino nano-t. Eszt szépen rá is kötöttem az első kimentre, de olyan problémám akadt, hogy ha a frekvencia 1470 Hz, akkor 5V helyett, csak 4-et ad ki. A másik problémám pedig az, hogy ezt a kód lefutása után, nem veszi el. Tudna valaki nekem ebben segíteni? Az 5V-os bemenet rendben van, elvileg a beállítások is és még a kimenő frekvencia is annyi, amennyinek kell.
Előre is köszi!


RJancsi | 1269    2016-05-26 11:54:00 [998]

Arra gondoltam, hogy kiforrasztom a munkaáram beállító potit és sorba kötök vele egy másikat, ami nem csavarhúzóval, hanem rendes tekerentyűvel állítható. Így a max áramot a trimmer korlátozza, a másikkal meg kedvemre csökkenthetem.

Előzmény: órafaragó, 2016-05-26 09:15:00 [997]


órafaragó | 278    2016-05-26 09:15:00 [997]

Tegyél neki olyan áramgenerátort amin lehet állítani az áramot. Állandó teljesítménnyel csak kínlódni fogsz vele.

Előzmény: RJancsi, 2016-05-25 23:54:00 [996]


RJancsi | 1269    2016-05-25 23:54:00 [996]

Mert az MK1 úgy tudom nem ad ki PWM jelet, a PicoLaser áramgenerátornak meg csak egy db optokapus bemenete van amivel a készenléti és a munkaáram között lehet váltani. Ezért próbálkoztam a sebességet variálni. A cncpart-tól kaptam egy levélkét, mely szerint a bemenetre egy potin keresztül adjam a kapcsolójelet, és azzal is lehet a teljesítményt módosítani. Ezt nem egészen értem, nem 5 V-os TTL jel kell neki? Az optokapu nem csak ki/be kapcsolni tud, van "köztes" állapota is?

Előzmény: órafaragó, 2016-05-25 22:39:00 [994]


bardosgy | 84    2016-05-25 23:10:00 [995]

Nekem ez van. Nem rombolom a topikot vele... röviden: teszi a dolgát

Előzmény: vadember, 2016-05-15 21:27:00 [973]


órafaragó | 278    2016-05-25 22:39:00 [994]

A lézer teljesítményét miért nem veszed lejjebb???

Előzmény: RJancsi, 2016-05-25 22:27:00 [993]

RJancsi | 1269    2016-05-25 22:27:00 [993]

Tudja a fene. De levettem a fehéret 500-ra, a feketét 100-ra és így már rendesen változtatja a sebességet, csak épp az 500-as "fehérnél" is feketére égeti a furnért, a 100-as feketénél meg át is lukasztja (1,5 mm-es borovi fenyő, ez volt itthon).

Előzmény: guliver83, 2016-05-25 22:06:00 [992]


guliver83 | 2470    2016-05-25 22:06:00 [992]

Nálam miért ment?
A programban a sebesség nem változott a te gépeden.
De az a lényeg, hogy már jó!

Előzmény: RJancsi, 2016-05-25 21:59:00 [990]


RJancsi | 1269    2016-05-25 22:01:00 [991]

... A feketénél ment max sebességen, a többi stimmel...

Előzmény: RJancsi, 2016-05-25 21:59:00 [990]


RJancsi | 1269    2016-05-25 21:59:00 [990]

Megtaláltam a hibát!termszetesen nem a program volt a hülye, hanem a felhasználó.A G-ray programban túl nagyra volt állítva "fekete" és a "fehér" sebesség. Gyakorlatilag már a fehérnél is max. sebesség környékén ment a gépem, csak valami miatt nem tiltakozott amikor a szürkéknél-fehérnél még gyorsabban kellett volna mennie. Egyszerűen ment a tőle kitelő maximumon és kész... A motorjaim 400-as osztásúak (0,9°-osak) és direktben hajtják a kis emelkedésű orsókat. 500 mm/min felett már hajlamosak lépést veszteni ill. csak fütyülni. Már jó ideje porosodik a polcomon 3 új trapézorsó, épp itt az ideje, hogy átépítsem a gépet.Még az sincs kizárva, hogy valami 1:2 gyorsító áttételt is be kéne raknom az x-y tengelyekhez, hogy rendes sebességet tudjak elérni. Gravírozáshoz a mostani is jó, de lézerhez kevés, a leggyorsabb tempónál is mindent eléget a tónusos pörkölés helyett.

Előzmény: RJancsi, 2016-05-25 09:51:00 [988]


guliver83 | 2470    2016-05-25 16:51:00 [989]

Küld már át a G kódot.

Előzmény: RJancsi, 2016-05-25 09:51:00 [988]


RJancsi | 1269    2016-05-25 09:51:00 [988]

Sziasztok!Újabb kérdésem merült fel... Megpróbálkoztam tónusos kép égetésével. A G-ray programmal generáltam a G kódot. Kinézetre jó is, a tónusokat kulturáltan előtolási sebességre alakította. Ám a vezérlőm nem hajlandó figyelembe venni az "F" értékeket, ugyanazzal a sebességgel megy végig. Mi ennek az oka? A CNCUSB program beállításaiban a sebesség menüben ki/be-pipáltam a "Sebesség felülbírálása" lehetőséget, de mindegy neki hogy be van-e állítva vagy nincs...


Danibá60 | 4070    2016-05-24 20:31:00 [987]


Bocs, most olvastam vissza. Látom, ezt már tudod.

Előzmény: Danibá60, 2016-05-24 20:28:00 [986]


Danibá60 | 4070    2016-05-24 20:28:00 [986]


Behívod a jegyzettömbbe a kódot. Megnyitod a csere menüt. És azt cseréltetsz amit akarsz.
Csak arra kell figyelni, a csere után ne egyezzen másik adatokkal. Mert nem tudsz rajta tovább változtatni ha kellene.
Először, egy másolattal gyakorolj. Ha elcseszed, ne legyen végzetes.

Előzmény: RJancsi, 2016-05-24 20:10:00 [985]


RJancsi | 1269    2016-05-24 20:10:00 [985]

Jól hangzik, de lövésem sincs, hogyan lehetne postprocesszort faragni a meglévő programjaim bármelyikéhez. Mivel időnként 3D-ben csinálok ezt-azt, most a marómotor helyett a lézer van a "Z" szánon, lehet, hogy megelégszem egy Word makróval, ami gombnyomásra kicseréli a "Z"-ket "M"-re. Primitív, de működik.

Előzmény: sanyi, 2016-05-24 20:03:00 [984]


sanyi | 1247    2016-05-24 20:03:00 [984]

Persze. Erre való a postprocesszor. Csak testre kell szabi az adott géphez.
Tulajdonképpen most te vagy a postprocesszor

Előzmény: RJancsi, 2016-05-24 18:10:00 [983]


RJancsi | 1269    2016-05-24 18:10:00 [983]

Köszi, jelenleg így működik. Csináltam egy egyvonalas kontúrgravírozó G kódot, amiben csak két "Z" magasság van, +5 mm és "-0,2". Utána egy sima szövegszerkesztővel (notepad) kicseréltem a "Z5,00000"-öt M5-re, a "Z-0,20000"-t M3-ra. Így már működik, de jobb lenne ezt egyből a szerszámpályával együtt generálni, hogy ne kézzel kelljen barkácsolni.

Előzmény: sanyi, 2016-05-24 17:08:00 [982]


sanyi | 1247    2016-05-24 17:08:00 [982]

A főorsót M3, M4 M5 kódok kezelik. Ennek megfelelő postprocesszort kell írni.
Az lehet kérdés mekkora késleltetéssel kezeli ezt a kódot. A lézerhez lehetőleg késleltetés nélküli végrehajtás kell, szóval lehet, hogy paramétereket kell változtani a megfelelő működéshez.

Előzmény: RJancsi, 2016-05-23 16:40:00 [979]


guliver83 | 2470    2016-05-24 15:28:00 [981]


Küldtem volna egy G kódot, hogy teszteld le de nincs e-mail címed az adatlapodban.

Küldj egy üzenetet és küldöm!

Előzmény: RJancsi, 2016-05-23 16:40:00 [979]


guliver83 | 2470    2016-05-24 15:11:00 [980]

Úgy kell generálni hozzá a G kódot.
Nem tudom, hogy miben tervezel, de a Post Processorát át lehet írni, hogy kapcsolja be neked a kimenetet.

Előzmény: RJancsi, 2016-05-23 16:40:00 [979]


RJancsi | 1269    2016-05-23 16:40:00 [979]

Sziasztok! Egy kis segítség kéne... Elnézést, ha korábban volt róla szó, de amíg visszaolvastam, nem láttam nyomát. Szóval van egy Planet MK1 CNCUSB alapon nyugvó gravírozóm, amit most kiegészítettem (fizikailag) egy 1W-os kék lézerrel. Jobb híján a lézert az OUT1 (spindle) portra kötöttem, és az ikont nyomkodva be/ki tudom kapcsolni. Ám hogyan lehetne ezt a G-kódba beépíteni, azaz milyen programmal lehet égetésre/vágásra alkalmas G kódot generálni?

kaqkk007 | 907    2016-05-15 22:01:00 [977]

Ez a cnc usb MK1


Ati | 392    2016-05-15 22:01:00 [976]

ja! ezt benéztem

Előzmény: kaqkk007, 2016-05-15 21:46:00 [975]


kaqkk007 | 907    2016-05-15 21:46:00 [975]

Ha a mach3 programmal akarod használni vedd meg , de mint már írtam ez nem "A" cncusb vezérlő tehát nem jó témában jársz, valószínűleg neki egy új témát kéne nyitni, mert ez itt a cncplanet (cncusb) vezérlő témája

Előzmény: Ati, 2016-05-15 21:40:00 [974]


Ati | 392    2016-05-15 21:40:00 [974]

Igen közbe megtaláltam én is, lehet kogy veszek egyet, ha nem beszéltek le róla, vagy van valami más hasonló árban?

Előzmény: vadember, 2016-05-15 21:27:00 [973]


vadember | 764    2016-05-15 21:27:00 [973]

Itt van eredeti oldal róla. Kell egy plugint telepíteni, hogy a Mach3 tudja rajta keresztül küldeni a jeleket.SainSmart USB vezérlő
A "click to download the documents" alatt le is töltheted, persze használni csak a kártyával együtt lehet.
Ha veszel egyet azért oszd meg a tapasztalatodat.

Előzmény: Ati, 2016-05-15 20:34:00 [970]


Fórum főoldal  |  A lap tetejére

Időrend:
Oldal 3 / 23 Ugrás ide:
|◄ Első  ◄ Előző  1 2 3  4   5   6   7     Következő ►  Utolsó ►|