HobbyCNC fórum
  v0.9 alpha

Fórum betekintő Fórum címe: http://forum.hobbycnc.hu



AC szervó motoros vezérlés

AC servo vezérlők és kiegészítői


Időrend:
Oldal 4 / 52 Ugrás ide:
|◄ Első  ◄ Előző  1 2 3 4  5   6   7   8     Következő ►  Utolsó ►|

Fórum főoldal  |  A lap aljára

sipos.janos84 | 83    2016-12-11 14:40:18 [2446]

Hello! vettem egy yaskawa 400w servot és vezérlőt az lenne a kérdésem, hogy egy joystick segítségével szeretném a motor mozgását szabályozni fokozat mentesen. Milyen ötletetek van erre ? bármi érdekel Esetleg még olyan is hogy a joy által leírt mozgást meg is tudja jegyezni és vissza tudja játszani a motor. Köszönöm szépen.


designr | 1858    2016-12-11 13:32:47 [2445]

A 10mb manual 31.oldalán megtalálod az 50-es I/O csati bekötéseit..UCCNC-vel Pablo használja..

Előzmény: nagaoka, 2016-12-11 13:03:11 [2443]


D.Laci | 3247    2016-12-11 13:19:25 [2444]

Ilyet még nem láttam de ez hátha segít: http://www.ware-tech.com/kr/_library/document/servo/samsung/CSD3%20Servo%20User%20Manual_en.pdf 5.2.3


nagaoka | 503    2016-12-11 13:03:11 [2443]

azután érdeklődőm,hogy ki használ CSD3Plus AC servo vezérlőt...esetleg UCCNC 300 párosítást. Esetleg az 50-es csati bekötése...step-dir, enable, végállások,stb a pontos tipusa:CSD3_04BX2 RS Automation


Földi Péter | 1000    2016-12-03 15:35:49 [2442]

Minden működik, az új PC, Servo-k,Driverek, Mach3. Szóval a BB volt a nagy buktató, ahogy Te is mondtad.Még egyszer köszönöm Mindenkinek aki segített! Üdv,Peti

Előzmény: svejk, 2016-12-02 12:16:51 [2440]

Földi Péter | 1000    2016-12-02 20:01:58 [2441]

Igen, ami lehetett az el is romlott. Mármint a servo-n kívül. Most élesztem a 478-as lapkát. Találtam még egy alaplapot, így WindowsXp+Mach+ próba sorrend következik. A moci szépen forog, a beállított sebességen (PN304). Itt még úgy néz ki, minden rendben.

Előzmény: svejk, 2016-12-02 12:16:51 [2440]


svejk | 24225    2016-12-02 12:16:51 [2440]

Ja, hogy még a PC-d is bozonytalansági faktor? Akkor első próbára laposelem, reszelő. Ha azzal már megy akkor majd ráérsz a PC-szoftver párost faragni.

Előzmény: Földi Péter, 2016-12-02 12:08:23 [2439]


Földi Péter | 1000    2016-12-02 12:08:23 [2439]

Délután fogok kimenni én magam is a műhelybe, de szerintem nem lesz gond. A BB volt itt a nagy kérdőjel, teljesen beleéltem magam, hogy erre szükség van (BB). Közben meg is feledkeztem arról, hogy a bemenetek amúgy is OC-vel galvanikusan leválasztottak. Ahogy írtad is, pontosan úgy van bekötve a szerkezet. Tegnap a PC-m megadta magát, befagy a MACH3 indítás után az egész OP rendszer, így egy telepítés után fogom indítani a ketyerét. Ha beindult, írok. De menni fog, nem lesz gond. A címzések rendben vannak a Sigmawin szerint is. Maszkoplás rendben. Mennie kell. Bárhogy is, leírom, mit láttam. Köszönöm MIndenkinek a taácsokat!

Előzmény: svejk, 2016-12-01 22:31:15 [2436]


Földi Péter | 1000    2016-12-02 12:03:49 [2438]

Hát lehet, hogy a "Shenzen"-i meghajtókat is lehetett volna opto coupler nélkül működtetni, ebben lehet valami. Az előadó úgy vállalta a garanciát a KIT-re, ha az általuk leírt módon a BB25 -el kerül meghajtásra a driver az eredeti leírásukkal egyetemben. Jogos meglátás, valószínűleg a TB-s sorozatú Step. drivereknél mindnél van OC-s leválasztás. Őszintén szólva nem is próbáltam nélküle. Megjött a csomag, 1 óra alatt már ment is a 4 tengely. Azért a Kínai driver integrált O.C.-s bemenetében annyira nem bíznék továbbra sem, ott inkább használnám a BB25-öt. A manó tudja már...

Előzmény: § Danibá60 § , 2016-12-01 23:04:06 [2437]


§ Danibá60 § | 3740
(Kitiltva 2017-08-25 20:00:00-ig!)
   2016-12-01 23:04:06 [2437]

Ezt leírhatnád, miért is lett mániád a BB, léptetőmotorok kapcsán? Ahhoz miért kellett?

Előzmény: Földi Péter, 2016-12-01 17:54:34 [2432]


svejk | 24225    2016-12-01 22:31:15 [2436]

A Yaskawa 8 és 12 lábát összekötöd és rákötöd az LPT 18-as lábára. A Yaskawa 7-es lábát rákötöd az LPT csati azon lábára amelyiken a Step jel jön ki. A Yaskawa 11-es lábát rákötöd az LPT csati azon lábára amelyiken a Dir jel jön ki. Innentől már csak servo paraméterezés kérdése, hogy megy vagy nem megy. (feltéve ha a mach3 jól van paraméterezve és biztos ki is adja a step jeleket. Egyelőre mindegy hogy aktív low vagy sem) Mentsd le a paraméterlistát és küld el, ha lesz egy kis időm holnap du. ránézek.

Előzmény: Földi Péter, 2016-12-01 21:56:38 [2435]


Földi Péter | 1000    2016-12-01 21:56:38 [2435]

Már a PIN2 és PIN3-ra értettem. A BB kiosztására gondoltam.

Előzmény: Földi Péter, 2016-12-01 17:55:37 [2433]


Földi Péter | 1000    2016-12-01 18:03:58 [2434]

Oksi, beakout likvidálva...

Előzmény: svejk, 2016-12-01 14:34:33 [2426]


Földi Péter | 1000    2016-12-01 17:55:37 [2433]

Pontosan így van.

Előzmény: Sz.József, 2016-12-01 14:43:00 [2428]


Földi Péter | 1000    2016-12-01 17:54:34 [2432]

A BB a léptető miatt a mániám... Dehogy akartam szivatni magam. Azt gonddoltam, hogy amolyan duplikált bizronsági módi az optót megpatkolni mégy egy o.couplerrel. Én sem értettem, de egy pár youtube video rámparancsolt. Már értem, szivattak...

Előzmény: svejk, 2016-12-01 14:34:33 [2426]

svejk | 24225    2016-12-01 15:45:12 [2431]

Én sem a könyveit sem az előadásait nem ismertem

Előzmény: ANTAL GÁBOR, 2016-12-01 14:55:23 [2429]


ANTAL GÁBOR | 3071    2016-12-01 15:34:54 [2430]

küldtem egy privát üzenetet ...

Előzmény: Földi Péter, 2016-12-01 13:57:01 [2424]


ANTAL GÁBOR | 3071    2016-12-01 14:55:23 [2429]

És én még azt hittem hogy csak én használom a reszelőt az élesztésnél ( de hisz mindketten mindhárman Öveges prof könyvein nevelkedtünk ) A legtöbbet akkor reszeltem amikor az első tirisztoros gyújtást csináltam úgy 74 ben

Előzmény: svejk, 2016-12-01 14:34:33 [2426]


Sz.József | 2786    2016-12-01 14:43:00 [2428]

Ja, hogy a Pin2 Pin3 az a Breakout board-on van "emlegetve"... Hát arra tényleg nincsen szükség... Lásd előző két bejegyzést...

Előzmény: Földi Péter, 2016-12-01 13:57:01 [2424]


svejk | 24225    2016-12-01 14:35:36 [2427]

De ha ragaszkodsz a bonyolult dogokhoz akkor keríts egy oszcilloszkópot és minden megvilágosodhat.

Előzmény: svejk, 2016-12-01 14:34:33 [2426]


svejk | 24225    2016-12-01 14:34:33 [2426]

Ad egy: Azért brummog mert pozicionál a szervo Ad kettő: Felejtsd már el a brekaoutos hóbelebancot!!! Csak szívatod magad amíg nem érted az egészet. Az első próbákhoz 230V hálózati feszültség, 3 szál drót és egy PC kell mach3-mal és mezei LPT prorttal. De a PC-t és a mach3-at egy dróttal és reszelővel is kiválthatod, azzal is tudsz step impulzusokat generálni. Ez utóbbi esetben még egy laposelemérre is szükséged lesz.

Előzmény: Földi Péter, 2016-12-01 13:57:01 [2424]


Sz.József | 2786    2016-12-01 14:19:52 [2425]

Ilyen vezérlőd van? Nem olvastam mindent vissza, de ezt hogyan kellene értelmezni?(Pi2, Pin3) ""Pin2-n a "PULS+" Pin3-on a "SIGN" ""

Előzmény: Földi Péter, 2016-12-01 13:15:26 [2423]


Földi Péter | 1000    2016-12-01 13:57:01 [2424]

Még valami, amit elszúrtam az írásomban A Breakout (Morvfer7-féle) Board PIn2-n a "PULS+" Pin3-on a "SIGN+". Itt kimaradt a (+), de ezt Te jól lekezelted. Az invertáló jelek közösítve földre húzva. AZ invertáló "PULS-" és "SIGN-"-ok összekötve és a Breakout board kártya GND-jére húzva. A Breakout egy független Ub=5V-os Nokia telefon tápegységtől kapja a tápot. A Yaskawa (SGDH-08AE Driver) (7)-es bemenetén a Breakout (2), azaz a PULS+, (8) GND árnyékoló harisnyán (11)-es tüskén a Breakout (3), azaz a SIGN+, (12)-en GND az árnyékoló harisnyán PN50A -nál 0x8170 -re PN50B -nél 0x6548 -ra PN000 -nál pedig 0x0010, azaz PULS üzemmód kiválasztva. Factory reset után írtam át a regisztereket. SON aktív bekapcsoláskor. Viszont ami fura, hogy enyhén brummog a motor, vagyis zümmög. De alig észrevehetően. Csak ha a kezemmel megfogom a tengelyt. Először azt hittem, gerjesztő áramok keletkeztek, aztán hálózati brummra gyanakodtam. A a MACH3-at és a PC-t kikapcsolva továbbra is fennáll. Ezt követően gondoltam arra, hogy talán az 1Ph alkalmazása (1 X 230V) okozhatja. Megcseréltem a drivert és a motort is egy-egy másikkal, de akkor is ugyanez. Viszont JOG módba ilyenkor nem tudok lépni (OP NO...) üzenettel zár a driver. Ha visszamegyek POT/NOT -ba, akkor gond nélkül. Remélem nem haragszol, hogy ilyen részletekkel traktállak és Korbendallas-nak is köszönöm, ha olvassa a sorokat. Üdv,Peti Láttam olyan megoldást (de nem értettem) ahol az invertáló "-" jelek is befutottak a Breakout-ba, de ezt nem igazán értettem.

Előzmény: Földi Péter, 2016-12-01 13:15:26 [2423]


Földi Péter | 1000    2016-12-01 13:15:26 [2423]

Igen, a motor típusát lehet, hogy nem írtam le. A típusa: SGMPH-08AAA41 A Driver: SGDH-08AE Köszi az infókat, végig járom, amt tanácsolsz.

Előzmény: ANTAL GÁBOR, 2016-11-30 21:16:43 [2421]


ANTAL GÁBOR | 3071    2016-12-01 06:44:07 [2422]

Valami szöget ütött a fejemben Azt írod : Pin2-n a "PULS+" Pin3-on a "SIGN" Az invertáló jelek közösítve földre húzva. A SGDH08 as vezérlő gondolom a szokásos optós bemenetű vagyis a benne lévő lednek az anódja a puls+ és a katódja a puls-. Minthogy a Pcben ( break bordban ) NPN tranyók vannak én azok kimenetét( kollektorát ) a puls- ra kötném miközben a puls+ ot feltenném +5 V ra ( egy áramutas rajz sokat segít ahol lerajzolod a ledet , előtétellenállást és a tranzisztort de az optós léptetővezérlőket is hasonlóan kötjük NPN tranyós meghajtás esetén ) Természetesen a dir ( sign ) nél is hasonlóan kell eljárni

Előzmény: Földi Péter, 2016-11-30 19:59:47 [2420]


ANTAL GÁBOR | 3071    2016-11-30 21:16:43 [2421]

Visszakerestem az első beírásig de lehet hogy elkerülte a figyelmemet : mi a motorod típusa ?

Előzmény: Földi Péter, 2016-11-30 19:59:47 [2420]


Földi Péter | 1000    2016-11-30 19:59:47 [2420]

Igen, szinte biztos, hogy valami triviális dolog lesz. A gond, hogy léptetőkkel próbálkoztam, de az AC világa számomra még hiányokkal teli. A PN50A és PN50B allokációnál vérzel el. Gondoltam, hogy ilyen amatőr AC-snek, mint én, hátha lesz a youtube-on egy szájbarágós videó, de meglepetésemre nem. Ráadásul szívesen tanulnék én bárkitől, de amint látom, nem publikálja igazán senki a kezdeti sikertelenségeket. Ezt még meg is tudom érteni. Én s leszek rá büszke, ha túl jutok rajta. Ha túl jutok rajta... Na de akkor bevallom és egy jót nevetünk rajta

Előzmény: ANTAL GÁBOR, 2016-11-30 17:30:14 [2419]


ANTAL GÁBOR | 3071    2016-11-30 17:30:14 [2419]

Nálam onnantól kezdve hogy : a leírt dolgok rendbe lettek téve kb 10 percbe tellett hogy működjön .

Előzmény: Földi Péter, 2016-11-30 17:18:42 [2418]


Földi Péter | 1000    2016-11-30 17:18:42 [2418]

Teljesen igazad van Gábor. De ha ennél kisebb lépésekkel haladok, akkor már visszafelé megyek... Végül is 4 éve építgetem a gépet. Rendszerprogramozóként szégyen gyalázat, hogy kifog rajtam a kütyü. De akárhogyan is, kifogott! Szigma win-em van, igen és a rövid kábellel próbáltam, amolyan száraz-járatással gyári kábellel. JOG rendben megy. Természetesen "RUN"-ban a JOG nem működik. A maszkolás mégsem lehet olyan tökéletes? Persze, nem adom fel, csak az időm kevés nagyon mostanában a bolyongásra. És hát mást sem teszek a napokban. Félek, megint elrakom egy 2 évre, ha nem jutok túl a buktatón. Kösz,Péter

Előzmény: ANTAL GÁBOR, 2016-11-30 07:45:23 [2416]


Földi Péter | 1000    2016-11-30 17:08:45 [2417]

Szia, Nagyon köszi, lehet, hogy élek a segítségeddel. Elszomorított, hogy nem övök rá. Üdv,Peti

Előzmény: korbendallas, 2016-11-29 22:39:34 [2415]

ANTAL GÁBOR | 3071    2016-11-30 07:45:23 [2416]

Nemrég én is harcoltam egy AC szervóval A tapasztalataim : Korrektül megcsinált kábelek kellenek Működő soros port ( nem árt egy echo val és a hiper terminállal leellenőrizni ) Szigma Win ( én a bétát preferálom ) Én nem használtam break boardot hisz a vezérlő optos bemenetű Step generátornak elég egy MPG egyik csatornája ( a dir meg direktben pl H ) Megfelelő maszkolás után mocorogni kell a motornak ha tekered az MPG t És ezután mehet a MACH ( akár break out boarddal ) Motto : csak kicsit lépünk egyszerre !!!

Előzmény: Földi Péter, 2016-11-29 22:26:46 [2414]


korbendallas | 408    2016-11-29 22:39:34 [2415]

Gyere el hozzám segítek beállítani. Tokodon lakom. Nincs messze

Előzmény: Földi Péter, 2016-11-29 22:26:46 [2414]


Földi Péter | 1000    2016-11-29 22:26:46 [2414]

Sziasztok, Hát, kezdem feladni. Új Breakout kártyával sem moccan meg a AC. A maszkolás rendben, megcsináltam, "RUN"-ban várná a jelsorozatokat, de semmi. Beállítás a Mach3-ban: Motor output Port1-en, Pin2-n a "PULS+" Pin3-on a "SIGN" Az invertáló jelek közösítve földre húzva. Nem tudom, hol vérzek el, Valamit elfelejtettem. Ha esetleg lenne ötletetek, előre is köszönet érte. Üdv,Peti

Előzmény: Földi Péter, 2016-11-29 00:28:36 [2413]


Földi Péter | 1000    2016-11-29 00:28:36 [2413]

Most már biztos, hogy a Breakout board játszott velem furcsa játékot. Morvfer-től vettem egy másikat, ha letesztelem, megosztom a tapasztalatot. Hátha más is jár így , mint én. Peti

Előzmény: Földi Péter, 2016-11-23 17:57:41 [2412]


Földi Péter | 1000    2016-11-23 17:57:41 [2412]

Felrakom, már keresgéktem is beta verziót. Köszi

Előzmény: korbendallas, 2016-11-23 06:26:53 [2410]


ANTAL GÁBOR | 3071    2016-11-23 16:33:48 [2411]

Fogadd meg Korbendallas javaslatát ! Kell egy Szigma Win!! Utána más színben fogod látni a világot ( én a bétát preferálom ) könnyű a beállítás és a maszkolás

Előzmény: Földi Péter, 2016-11-22 23:18:54 [2409]


korbendallas | 408    2016-11-23 06:26:53 [2410]

Lehet. Javaslom tedd fel a sigmawin-t. Lehet vele offline módban dolgozni. utána csak át kell írni a kijelzőn a pár beállított paramétert.

Előzmény: Földi Péter, 2016-11-22 23:18:54 [2409]


Földi Péter | 1000    2016-11-22 23:18:54 [2409]

Igen, a Fn005 -->Fatory reset megvolt már. A Pn50A.1 -et nem "7"-re kell rakni? (enable all) Csak tapogatózom ám, már semmi sem bizti

Előzmény: korbendallas, 2016-11-22 22:44:38 [2408]


korbendallas | 408    2016-11-22 22:44:38 [2408]

Először állítsd vissza a gyári beállításokat. Az is benne van valahol a leírásban

Előzmény: Földi Péter, 2016-11-22 22:16:30 [2407]


Földi Péter | 1000    2016-11-22 22:16:30 [2407]

Köszi szépen. Egyébként folyamatosan a leírásait nézem az SGDH családnak, de kell még egy pici idő, hogy a végére érjek a több, mint 800 oldalnak a frissítéseket beleszámolva. Sajnos az idő szab határt a terveknek, amiből egyre kevesebb akad. Ha már megmozdula szegényke, más lenne a cél. Szóval erre gyúrok én, már-már megszálottan... Az a gyanúm, hogy az input allocation table van szétirva, és valahonnan máshonnan várja a bemeneti jelszinteket. De majd egyenként végig gurulok rajtuk. Illetve a breakout board is kehrt hibás. Túl sok a változó egyenlőre. Ezért minden tanács jól jöhet. Biztos valami profád dolog lesz...Üdv,Péter

Előzmény: korbendallas, 2016-11-22 17:09:33 [2406]


korbendallas | 408    2016-11-22 17:09:33 [2406]

Pn50A.3=8 Pn50B.0=8 Pn50A.1=8 Pn000.1=1 A leírásban benne van. Érdemes alaposan átnézni.

Előzmény: Földi Péter, 2016-11-21 13:42:04 [2404]


D.Laci | 3247    2016-11-22 14:31:59 [2405]

Thomson Omni Link vagy Giddings Lewis DSMPro (Kollmorgen), szoftverrel rendelkező segítségét keresem.


Földi Péter | 1000    2016-11-21 13:42:04 [2404]

Ha jól gondolom, a Pn50A.1-et kell szerintem 7-es értékre állítani, azaz a regiszter 2.digitjét. Legalábbis így lehet engedélyezettként beállítani a Yaskawa-t, ha jól nézem. A terminológia messze van a PC-től, de megszokom majd. Hazamegyek, tesztelek. Kösz a tanácsot.

Előzmény: designr, 2016-11-21 13:15:35 [2403]


designr | 1858    2016-11-21 13:15:35 [2403]

Más tipusom van de.. A Servo On..tehát a szervó bekapcsolást..engedélyt ha szoftverből csinálod.akkor megkeresed a digitális bemeneteknél hol van..jelenleg mire van állítva..Lehetséges hogy a bekapcsolás az egyik digit bemenetre van beállítva..ilyenkor vagy egy tápegység és jelet adsz neki..vagy beállítod hogy ez a bemenet mindig ON legyen..elmented..ezt ugy fogja látni mintha adtál volna neki bekapcsoló jelet..

Előzmény: Földi Péter, 2016-11-21 12:22:48 [2402]


Földi Péter | 1000    2016-11-21 12:22:48 [2402]

Szia, Igen, már csak azt bogózom, hogyan tudom megoldani. Azt hittem, hogy lesz némi előnyöm a végzettségem okán, de tévedtem. Ez egy más Világ, de még nem a másvilág. Igen rafinált a struktúra a I/O Signal Control-nál az AC-k világában. Ez a jelenlegi tudásom alapján még nekem kínai. Kösz,P

Előzmény: korbendallas, 2016-11-21 00:11:57 [2399]

Földi Péter | 1000    2016-11-21 12:19:15 [2401]

Szia, Őszintén szólva az AC servo nekem meglehetősen új a léptetők után. Még barátkozom csak. A Servo ON-t (SON) még nem tudom, hogyan kell maszkolni. Jól gondolom, hogy a PN50A (n.2100) regisztert kellene beállítanom? Elvesztem a részletekben. A maszkot egyébként egy "1111" jelsorozathot maszkolja hozzá "ÉS" kapcsolattal, akár a TCP/IP-k esetében a PC-nél? Köszi,P

Előzmény: svejk, 2016-11-21 06:30:26 [2400]


svejk | 24225    2016-11-21 06:30:26 [2400]

A Son-t maszkolni kell, és akkor már bekapcsoláskor rögtön fogja a motort.

Előzmény: Földi Péter, 2016-11-20 22:19:10 [2397]


korbendallas | 408    2016-11-21 00:11:57 [2399]

Nem kell hozzá külső táp

Előzmény: Földi Péter, 2016-11-20 22:19:10 [2397]


Földi Péter | 1000    2016-11-20 22:53:53 [2398]

Elírtam, helyesen 42-43 lábakra gondoltam.

Előzmény: Földi Péter, 2016-11-20 22:19:10 [2397]


Földi Péter | 1000    2016-11-20 22:19:10 [2397]

Sziasztok, Azt hiszem én is segítségre szorulok. Egy Yaskawa SGDH-08AE drivert kötöttem be és a "POSITION CONTROL" módban a Mach3 semmit nem tesz. JOG módban (manual) működik persze. Lehet, hogy a +24V külső táp miatt lenne? Azt a tanácsot kaptam a CNCDRIVE-ról, hogy megkerülhető a külső táp és anélkül is működik a "step/dir" mód. Ha ez nem így lenne, akkor egy külső tápot vadásznék jozzá. Nagyon köszönöm, ha valaki segítene a dologban. A Pin42-Pin42 lábak külső tápjára gondolok, természetesen. Köszönöm,Peti


Fórum főoldal  |  A lap tetejére

Időrend:
Oldal 4 / 52 Ugrás ide:
|◄ Első  ◄ Előző  1 2 3 4  5   6   7   8     Következő ►  Utolsó ►|