HobbyCNC fórum
  v0.9.2.4

Fórum betekintő Fórum címe: http://forum.hobbycnc.hu



LinuxCNC a gyakorlatban

xxxx


Időrend:
Oldal 2 / 89 Ugrás ide:
|◄ Első  ◄ Előző  1 2  3   4   5   6     Következő ►  Utolsó ►|

Fórum főoldal  |  A lap aljára

smalla | 904    2017-03-26 14:16:56 [4370]

Igen, ezt olvastam, sajnos ez a day of month xor mintha itt nem működne, valami más az algoritmus sztem. Ezt volna jó kitalálni

Előzmény: horcsab, 2017-03-26 10:31:26 [4369]


horcsab | 292    2017-03-26 10:31:26 [4369]

Ezt gondolom megtaláltad. Link Igaz, nem pont az a típus, de talán kiindulásnak nem rossz.

Előzmény: smalla, 2017-03-25 21:29:11 [4367]


KoLa | 5970    2017-03-25 21:55:41 [4368]

Nem kell az index jel ahhoz hogy elinduljon a menetvágás!kipróbáltam! kiszámolja szerintem az A phase configból is, és indul akkor is ha nem jön az index jel, csak ebben az esetben nem talál vissza a menetárokba! Nincs ebből probléma, csak a működési elvet cikizem! Ha van korrekt index jel akkor téveszthetetlenül működik! Az A-B phase használata is nagy különbséget eredményez ha pl csak A phaze van a configban!de ezt, Te biztos tudod csak úgy megjegyzem.

Előzmény: D.Laci, 2017-03-24 06:04:07 [4365]


smalla | 904    2017-03-25 21:29:11 [4367]

Éljen, az első 3 gomb működik. Kéne némi help, mert nem jövök rá magamtól: ki kellene találni, hogy a második és nyolcadik oszlopban mi alapján változnak a számok, felajánlok egy tábla csokit a megfejtőnek. 04 40 01 00 0E 13 00 7F 04 57 00 00 0E 13 00 04 04 0E 01 00 0E 13 00 0F 04 DE 00 00 0E 13 00 0C 04 21 01 00 0E 13 00 01 04 CC 00 00 0E 13 00 0C 04 C1 01 00 0E 13 00 01 04 18 00 00 0E 13 00 08 04 E4 01 00 0E 13 00 03 04 A9 00 00 0E 13 00 08 04 BF 01 00 0E 13 00 0D 04 71 00 00 0E 13 00 00 04 DC 01 00 0E 13 00 0B 04 A9 00 00 0E 13 00 08 04 D5 01 00 0E 13 00 05 04 04 00 00 0E 13 00 04 04 65 01 00 0E 13 00 05 04 0C 00 00 0E 13 00 0C 04 D4 01 00 0E 13 00 03 04 E4 00 00 0E 13 00 04 04 77 01 00 0E 13 00 05 04 D7 00 00 0E 13 00 04 04 8C 01 00 0E 13 00 0B 04 4A 00 00 0E 13 00 08 04 CB 01 00 0E 13 00 09 04 06 00 00 0E 13 00 04 04 45 01 00 0E 13 00 05 04 FD 00 00 0E 13 00 0C 04 3C 01 00 0E 13 00 0B 04 0A 00 00 0E 13 00 08 Csak az 1-es gombot nyomogattam, ami a 3. oszlopban látható változás. De a 2. és 8. oszlopok számomra ismeretlen konstellációban változnak minden alkalommal. Erre kéne rájönni. Köszi


GG | 62    2017-03-24 08:24:13 [4366]

Pedig de. Irok neked.

Előzmény: smalla, 2017-03-23 23:50:35 [4364]

D.Laci | 3478    2017-03-24 06:04:07 [4365]

Én úgy emlékszem, hogy kel az index jel, hogy elinduljon a menetvágás.

Előzmény: KoLa, 2017-03-23 22:31:58 [4363]


smalla | 904    2017-03-23 23:50:35 [4364]

Hah, nincs másik, ami tudna 5 tengelyt. Ezt kell megoldanom.

Előzmény: guliver83, 2017-03-23 20:28:13 [4362]


KoLa | 5970    2017-03-23 22:31:58 [4363]

Néhány érdekességre akadtam a Linuxcnc-vel kapcsolatban! Persze ez egy eszterga! Hibakeresés közben lehúztam az index jel, és az A phaze csatikat, menetvágás közben, felváltva! A tapasztalat: a Linuxcnc-nek nem kell index jel a menetvágáshoz, akkor is vágja ha nincs, csak nem talál bele! Az A phase jel sokkal fontosabb számára, ha ez nincs akkor nincs főorsó fordulatszám kijelzés, és nincs menetvágás sem!és nincs semmiféle mozgás, programból vezérelve ha At speed van a configban! Linuxcnc esztergályosok, próbáljátok már ki! Nálatok is ez van?


guliver83 | 2426    2017-03-23 20:28:13 [4362]

Szerintem vegyél egy másikat amit használni is lehet. Ezt meg tedd vissza a dobozába majd érte megyek!

Előzmény: smalla, 2017-03-23 17:13:55 [4361]


smalla | 904    2017-03-23 17:13:55 [4361]

Odáig már eljutottam, hogy a driver betöltődik mert az usb ID-t átírtam, de a kommunikáció más. Valamit csinál, mert ha tekergetem az mpg-t meg nyomogatom a gombokat, akkor random történik valami, és a kijelzőn is feltűnnek karakterek, de ennek nyilván nem így kellene működnie Ezért kellene az USB kommunikációt valahogy lehallgatni, ehhez kellene valami tool vagy valami tapasztalat, hátha valaki már csinált ilyet.

Előzmény: GG, 2017-03-23 15:26:44 [4360]


GG | 62    2017-03-23 15:26:44 [4360]

Azzal a módszerrel, ahogy a hb04-nél le van írva. Szerintem a vendor:product id-ket kell aktualizálni, és a tesztprogi alapjan a configot megcsinalni. Szerintem.

Előzmény: smalla, 2017-03-23 09:17:16 [4357]


Pál | 7530    2017-03-23 09:36:57 [4359]

Most látom ez a WiFi-s verzió. Én a vezetékest teszteltem.

Előzmény: Pál, 2017-03-23 09:32:48 [4358]


Pál | 7530    2017-03-23 09:32:48 [4358]

Én eleve valami USB monitorozó szoftvert néznék a neten és az eredeti környezetében vizsgálnám. A másik megoldás ezt szépen visszacsomagolod felteszed a fórumra és rendelsz egy megfelelőt. Utóbbival sok kellemetlenségtől kímélnéd meg magad. Ez az én véleményem. Mivel volt ilyenhez vagy hasonlóhoz szerencsém tesztelni Mach alatt. Az láttam, hogy ipari környezetben ez is mint az összes USB periféria meghal, a kommunikáció összeomlik. Már egy frekvenciaváltós motor indításától is képes volt " lefagyni ". Maga az eszköz használhatóság szempontjából még jó is lehetne, ha nem lenne rajta az a fránya USB.

Előzmény: smalla, 2017-03-23 09:17:16 [4357]


smalla | 904    2017-03-23 09:17:16 [4357]

Vettem nemrég egy ilyet: WHB04B-6 sajnos ez nem az, mint az XHC-HB04, amihez a linuxcnc alatt van support. Ezért hát elkezdtem írni hozzá a megoldást az xhc-hb04 alapjaira. Ha valaki tudna segíteni, hogy hogyan is kell az USB kommunikációt debuggolni, visszafejteni, aztán azt implementálni a kódba, akkor gyorsabban haladnék. Mivel ilyet még nem csináltam azt se tudom, hol álljak neki. (a linuxcnc.org-os hasonló fórumtémát is én nyitottam, de elég lassú a válaszidő ottan, hátha itt több szerencsével járok.) Köszi


horcsab | 292    2017-03-22 06:58:47 [4356]

PC-n megy. Ott nincs gond. Annyit közben elértem, hogy Tkemc-vel megy. Már csak az Axis-al kellene megoldani.

Előzmény: remrendes, 2017-03-22 00:55:20 [4355]

remrendes | 1437    2017-03-22 00:55:20 [4355]

Tedd fel valahova, hatha valaki kiprobalja PCrol.

Előzmény: horcsab, 2017-03-21 18:31:22 [4354]


horcsab | 292    2017-03-21 18:31:22 [4354]

Bocsi, igaz kiírhattam volna, hogy Beaglebone black-ról van szó. Szóval az 512M tényleg kevés, ráadásul axis képernyőt használom. Tkemc-vel is ugyan ez a helyzet. SWAP-ot 1Gb-ot adtam hozzá, de nem itt van a baj.

Előzmény: korbendallas, 2017-03-21 09:16:20 [4349]


korbendallas | 418    2017-03-21 10:39:03 [4353]

Én is beírtam a google-ba

Előzmény: D.Laci, 2017-03-21 10:06:20 [4352]


D.Laci | 3478    2017-03-21 10:06:20 [4352]

Bevallom utána kelet nézek, hogy mégis miről lehet szó.

Előzmény: korbendallas, 2017-03-21 10:02:02 [4351]


korbendallas | 418    2017-03-21 10:02:02 [4351]

Ugye hogy le lehet írni normálisan is. Így már értem. Szerintem kevés az az 512Mb memória...

Előzmény: D.Laci, 2017-03-21 09:32:15 [4350]


D.Laci | 3478    2017-03-21 09:32:15 [4350]

Én inkább BeagleBone Black vagy Blue -ra gondolnék.

Előzmény: korbendallas, 2017-03-21 09:16:20 [4349]


korbendallas | 418    2017-03-21 09:16:20 [4349]

Nem hiszem hogy azért nem tudod betölteni a linuxcnc-be a g kódot mert Big Brothers Brasil-el foglalkozol. Próbáltál már több memóriát rakni a gépbe?

Előzmény: horcsab, 2017-03-21 07:40:43 [4348]


horcsab | 292    2017-03-21 07:40:43 [4348]

Foglalkozik itt valaki BBB-el? Van egy 130Mb-os G kódom (egy kép), ami miatt "out of memory" hibával megáll a kód betöltése közben. Megoldást még nem találtam rá. Valaki esetleg járt már így? Ha igen és sikerült megoldani a akkor megosztaná a megoldást?


remrendes | 1437    2017-03-10 20:39:56 [4347]

Kicsit csalodott vagyok a Max Jitter ertekeimen. A Servo thread sorban 14400ns-ot ir. Nezegettem a Latency ertekeket a neten. Elmeletileg C2D procival egy ASUS P5B alaplap teljesitene a legjobban, 3200-at irnak hozza. Erdemes lenne lecserelnem egy adando alkalommal?


vjanos | 4517    2017-01-28 16:06:21 [4346]

Gratula! A konfigot közzéteszed, hogy tudjon tanulni belőle aki két MPG-t akar?

Előzmény: guliver83, 2017-01-28 15:20:11 [4345]


guliver83 | 2426    2017-01-28 15:20:11 [4345]

Linuxcnc-vel minden gond elhárítva! Tökéletes a 2db kézikerék és a felbontás is tuti lett! Csak gondoltam leírom.


horcsab | 292    2017-01-24 18:43:02 [4344]

Szia! Lökd át a konfig file-okat. Mindet. Megnézem, hátha rájövök.

Előzmény: guliver83, 2017-01-24 16:35:07 [4339]


guliver83 | 2426    2017-01-24 17:53:41 [4343]

Igen szerintem az. De azért tettem bele egy kártyát és azzal nincs most gond szépen megy.

Előzmény: remrendes, 2017-01-24 17:26:31 [4342]


remrendes | 1437    2017-01-24 17:26:31 [4342]

Nem a videokartya, csak a firmware-e.

Előzmény: guliver83, 2017-01-24 17:22:25 [4341]


guliver83 | 2426    2017-01-24 17:22:25 [4341]

Akkor hallgatlak. Mi lehet a hiba? Nem hiszem, hogy a videokártya lett volna a hibás vagyis az alaplapi, mert XP alatt megy rendesen.

Előzmény: vjanos, 2017-01-24 17:19:41 [4340]

vjanos | 4517    2017-01-24 17:19:41 [4340]

A videokártyát is én mondtam...

Előzmény: guliver83, 2017-01-24 16:35:07 [4339]


guliver83 | 2426    2017-01-24 16:35:07 [4339]

Senki nem használja a LinuxCNC lefagyott ez az oldal. Mindenre nekem kell rájönni? Találkozott már valaki olyan problémával, hogy kézikeréknél a lépésköz beállítással gondok voltak? 8-9 lábra van állítva a lépésköz két bemenete. Alap állapotban 8-9 láb 1k ellenállással +5V van húzva olyankor kellene mennie 1mm de csak 0,413mm megy sajnos erre nem tudok rájönni, hogy mi lehet a hiba. ha a 8 lábat GND re húzom akkor 0,1mm ha a 9 lában akkor 0,01mm ezek tökéletesen működnek de az 1mm felbontás nem. És a 2db kézikerék egy esztergán tökéletesen működik


guliver83 | 2426    2017-01-22 22:57:37 [4338]

Érdekes igaz Az alaplapi videokártya volt a hibás. Tettem bele egy videókártyát most úgy néz ki tökéletes. Közben átkapcsoltam a monitort másik gépre.

Előzmény: zozo, 2017-01-22 21:29:08 [4337]


zozo | 2773    2017-01-22 21:29:08 [4337]

Ezt meg hogyan csinálja? Külön partícióra tetted a linuxot? Ugye nem futó win alá telepítetted valami virtuális boxba...

Előzmény: guliver83, 2017-01-22 15:58:04 [4334]


guliver83 | 2426    2017-01-22 16:41:10 [4336]

Alaplapiról megy.

Előzmény: vjanos, 2017-01-22 16:18:39 [4335]


vjanos | 4517    2017-01-22 16:18:39 [4335]

Nvidia videokártya? Valami driver gond lesz...

Előzmény: guliver83, 2017-01-22 15:58:04 [4334]


guliver83 | 2426    2017-01-22 15:58:04 [4334]

Találkozott már valaki ilyen hibával? Telepítettem a debian Linuxcnc programot megy is egy ideig aztán újraindítás után össze vissza vibrál a kép. Főleg ha az egeret mozgatom. A videón lehet látni hogy mit is csinál. A videó végén a monitor átkapcsol win7 re. Video


KoLa | 5970    2017-01-21 20:19:31 [4333]

Ha megnyitom akkor már én is tudom csak nem a Linux-on netezek. Ez azért érdekes!hogy Te is azt tapasztalod hogy néha másként működik! Azt gondolnám hogy az ini fájl az egy szentírás, ugyanúgy mint a hal file, vagy bármi ami a config-ban le van írva!és csak a fejlécben lehet tenni ellene, vagy bárhol a kódban ha szükséges!

Előzmény: lari, 2017-01-21 15:22:29 [4331]


KoLa | 5970    2017-01-21 20:10:19 [4332]

Köszi a linket! ismerem! csak nekem is magas mint "kacsának az eperfa" mifelénk ezt, így mondják! Nem vettem észre a gépemen a rángatást, g61 alatt, amit írsz! Lehet hogy, azért mert, léptetős, és nem tud nagy gyorsulásokat, így finomabban fordul!

Előzmény: Motoros, 2017-01-21 15:06:12 [4330]


lari | 988    2017-01-21 15:22:29 [4331]

Ini fájl, programértelmező részhez be lehet írni azokat a G utasításokat, amit szeretnél, hogy alapból indítson a program... #RS247NGC_STARTUP_CODE Ennek ellenére a g kód program bevezető fejlécében is fel kell tüntetni azokat, amire szükség van, mert nem minden esetben elég az INI-ben megjelölt rész. Legalábbis én így tapasztaltam...

Előzmény: KoLa, 2017-01-21 14:02:34 [4329]


Motoros | 3898    2017-01-21 15:06:12 [4330]

Na ez remek. Akkor kiderült hogy az én 2.5 verzióm ezt másképpen csinálja, az én esetemben nem egyformán hat a G64 a G0 és G1-re, míg a Te verziódnál egyformán, és ez így korrektebb. Viszont akkor az is látszik, hogy kell a G64 méghozzá a legjobb ha P0.01-el használva. A G61 azért nem jó mert ha kontúr programot írsz akkor rángatni fog. EZT az oldalt biztosan ismered, és van is itt valami róla de ez nekem magas mint kacsának a gólyafészek. Ehhez Sneci kellene, vagy János.

Előzmény: KoLa, 2017-01-21 14:02:34 [4329]


KoLa | 5970    2017-01-21 14:02:34 [4329]

Kipróbáltam ezt a kis mozgást amit küldtél! Reggel bekapcsolás után betöltöttem! Az első próba home all után g64 nélkül A második próba g64 p0.1 -el A harmadikban a g64 p0.1 -et g61-re cseréltem Azután újból kitöröltem ezt a sort , se g61, se g64, de már azt az első nagy rádiuszt nem adta,hanem a második verzióval rádiuszolt. Azt gondolom hogy nekem az ini fájlba kell beírni hogy alapban g61-el induljon, valahol be lehet ott írni egy csomó g kódot, amivel akarjuk hogy induljon a program!

Előzmény: Motoros, 2017-01-21 08:07:54 [4328]


Motoros | 3898    2017-01-21 08:07:54 [4328]

Akkor próbáld már ki a G64 P0.01 sort a kedvemért. Jónak kell lenni...szerintem.

Előzmény: KoLa, 2017-01-20 22:30:35 [4326]


KoLa | 5970    2017-01-20 22:46:08 [4327]

Léptetős esztergáról van szó!

Előzmény: korbendallas, 2017-01-20 07:18:28 [4320]


KoLa | 5970    2017-01-20 22:30:35 [4326]

Az a probléma hogy ha g0-val mozgok, külön mondatban,két sorban leírva akkor,lekerekíti a sarkot! így ha az anyagot akarom kikerülni akkor simán beletolja! A régebbi Linuxcnc verzióknál és a Mach3-nál sem volt ilyen hibám, csak az utóbbi két évben kell figyelni erre, amióta 2.8 pre1 van fenn.Az első sorba írt g61 megoldja ezt a problémát. Ma,az első darabnál lekerekítette a gyorsjáratot, a derékszögű mozgás helyett! A másodiknál már betartotta a szabályt! ponttól-pontig ment, minden fogás után!Na!ez itt a kérdőjel!mitől függ hogy éppen levágja a derékszöget egy állandó sebességű mozgásra, vagy pontig megy? Te biztos tudod hogy, esztergáról van szó,de ideírom hogy a g0 az ponttól pontig kell hogy menjen minden gépen, mert különben nem bízom a gépemben! Keresem már a képernyőmentést, amit egy éve csináltam egy látványos szerszámpályáról, csak nem találom... Holnap majd betöltöm ezt a pár sort próbára, és majd beszámolok!

Előzmény: Motoros, 2017-01-20 10:38:04 [4324]

Motoros | 3898    2017-01-20 10:39:27 [4325]

Ja nekem a 2.5 verzió van fent, de ez gondolom nem számít.

Előzmény: Motoros, 2017-01-20 10:38:04 [4324]


Motoros | 3898    2017-01-20 10:38:04 [4324]

Nem emlékeztem már pontosan mi is volt ezzel a rádiuszzal, milyen esetben hogyan változik és mi van a grafikán. Most írtam egy kis tesztet ami mutatja mi is van. G54 G64 P0.1 (ezt a sort töröld vagy írd át a P1 re vagy hagyd ki a P-t, vagy írj G61-et ) G0 X0 Z0 G1 Z-5 F1000 G1 Z0 G1 X5 G1 X0 Z0 G0 Z-5 G0 Z10 G0 X5 M30 Ha ezt futtatod akkor mutatja a G0 és G1 esetén a lekerekítési sugár számolt változás a grafikán, ha jól ránagyítasz és frissítesz. A G1 sugár töredéke a G0-nak, itt valami viszonyszám játszik Tehát ha G64 után nem írsz semmit akkor lehet az ini fájlból vesz valamit, ezzel nem játszottam, nézz utána. De az a biztos ha G64 P0.01 és kész.

Előzmény: KoLa, 2017-01-19 22:08:16 [4319]


korbendallas | 418    2017-01-20 07:54:18 [4323]

Én nekem az tetszik benne, hogy tudom mindig hol van a szerszámom vége Pl: valami biztonsági retesz kioldása miatt lekapcsolódnak a szervók, vissza tudok állni simán ahova akarok pontosan.

Előzmény: vjanos, 2017-01-19 10:22:37 [4314]


korbendallas | 418    2017-01-20 07:35:38 [4322]

traj igaza van smalla-nak

Előzmény: KoLa, 2017-01-19 22:08:16 [4319]


korbendallas | 418    2017-01-20 07:22:04 [4321]

Mondjuk ebből nem hiszem, hogy r10 rádiusz jönne ki


Fórum főoldal  |  A lap tetejére

Időrend:
Oldal 2 / 89 Ugrás ide:
|◄ Első  ◄ Előző  1 2  3   4   5   6     Következő ►  Utolsó ►|